Help - Search - Members - Calendar
Full Version: Dev_img-1.6 Setup Trouble
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > OpenZaurus/Opie/Qtopia
Meyer
dev_img-1.5 worked fine until several months ago when gcc started segment faulting. Decided to try upgrading to 1.6 to solve the problem, but I can't get the set-up script to run successfully. Does something need to be installed first to use squashfs instead of the previous image's cramfs? Have tried running more than once removing all the 1.5 configuration I could find.

CODE
# sh image_setup.sh /usr/mnt.rom/card/dev_img-1.6 /mnt/dev
Setting mount point /mnt/dev...
Mounting image /usr/mnt.rom/card/dev_img-1.6...
mount: Mounting /usr/mnt.rom/card/dev_img-1.6 on /mnt/dev failed: No such device
Failed to mount image /usr/mnt.rom/card/dev_img-1.6 on /mnt/dev


Is there a better forum for this topic?
speculatrix
check that the file on your SD card is actually there, and has non-zero size.

/usr/mnt.rom/card/dev_img-1.6

I think, from memory, that /mnt/card is a link to /usr/mnt.rom/card so check both locations, maybe the soft link is broken, the card isn't being mounted correctly (using fat16, fat32 or ext2/3??), or the file is corrupted??
Meyer
Having made no progress on this problem, I've been making-do with zgcc for on-board compiling for the last few months, until today when I wanted to compile something that uses the curses library. Finding no IPKG for libcurses, I decided to give dev_img-1.6 another try.

Still no success, but I may have found the cause for image file failing to mount. My kernel is version 2.4.18-rmk7-pxa3-embedix (Sharp ROM 1.31 JP), but my squashfs module is compiled for kernel 2.4.20. This give me three possible ways forward:
  1. Find a squashfs IPKG for kernel 2.4.18...
  2. Find a copy of dev_img-1.5, which uses known-to-work cramfs instead of squashfs.
  3. Compile squashfs myself, which will require a kernel patch.

Anyone know where I can find the targets of 1. or 2., or a painless way to do 3.?

Zaurus is SL-C860.
sdjf
I don't have the patience to wade through the results but you might also try google's code search:

http://google.com/codesearch?hl=en&lr=...amp;btnG=Search

Anything useful there? Nothing came up for the dev img you wanted. Might also try meta engine like dogpile.com

When we needed a copy of my 2.4.6 kernel, I used google to help me locate people who had been involved in development of applications for it, and one of them still had a copy and pointed us to the right ftp sites.

Hopefully someone here will see your query and respond.
sdjf
speculatrix
when I made a squashfs archive of the oesf forums, I had to use an old version of squashfs - version 2.

new kernels with squashfs v3 filesys will mount old v2 files, but not vice versa.

some notes/comments here: http://www.zaurus.org.uk/squashfs.html
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.