I'd tried controlling my Linux desktop machine from my Z using teakettle (the modded keypebble VNC viewer) but I found the screen often didn't update and so it was unusable- the performance was nothing like a video I'd seen of someone using XP over RDP on their Z so I was disappointed at first.

The desktop Linux machine I'm typing this on is running Ubuntu Gutsy - xrdp isn't in the ubuntu repos yet but it turns out that it was WELL worth the effort of compiling it as running xrdp on my ubuntu box and qtrdesktop under Cacko has brought me a very responsive remote GNOME desktop on my Z and it really is like having a brand new Zaurus now - xrdp and qtrdesktop work so well that even video playback under GNOME is near watchable over a wifi link.

The major showstopper for me now is that the keymap on the Zaurus (from the real or on-screen keyboard) is all wrong under qtrdesktop. My keyboard is set correctly and works fine under all other Cacko apps of course but Ubuntu Gutsy doesn't seem to have an approriate option for a c3000 keymap under the GNOME Keyboard config tool so I was wondering if anyone here has encountered and hopefully solved this problem. Maybe its a xrdp bug?

If you've not tried this already I'd highly recommend trying xrdp with qtrdesktop - its brought a whole new dimension to my Z and it will be quite usable for web browsing and lots of other things that were a bit too slow under pdaX or just not possible under Cacko - when I get the keyboard working under qtrdesktop!!