Help - Search - Members - Calendar
Full Version: Wireshark On Pdaxiiv2
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
climber
Meanie,

I upgraded my SL-C3100 v5.4.9 to your newest version of pdaXii13v2. I installed wireshark_0.99.6_armv5tel.ipk from
your pdaXii13v2 feed.

When I start it from command line I get the following error:

wireshark; error while loading shared libraries: /usr/lib/libportaudio.so.:
cannot open shared object file: No such file or directory

Searching for this file I found it on: /opt/native/arm/3.4.6-xscale-softvfp/arm5tel-cakco-linux/lib/lipportaudio.so
Then I created a symlink (ln -s) from this path to the /usr/lib/

Starting wireshark again: ......
..... Error 40


Do you have a idea why this do not work? dry.gif

Thanks
climber

Jon_J
I did a search for "lipportaudio" and only found this thread, and your more recent one.
I'm pretty sure the path below is created when you have zgcc-3.4.5-4.squashfs mounted, (or 3.4.6 version).
I would just copy
/opt/native/arm/3.4.6-xscale-softvfp/arm5tel-cakco-linux/lib/libportaudio.so
to
/usr/lib/lipportaudio.so

I don't have a compiling setup at the moment. I tried it last Winter, but some of the stuff went over my head. sad.gif

Another question, Do you have the full "spitz" version of pdaxii13 installed?
This library may be contained in another library in the "full" version.
I searched inside "hdimage-full.tgz" of "build-5.4.9-beta" and didn't find "libportaudio.so" in any of the usual places.

I just have the "Akita" version of pdaXii13v2 installed on my C3200 and didn't find this lib on my Zaurus.

On an unrelated subject:
I noticed that "Wifi-Radar" requires "flite" for some audio stuff, but it works for me without "flite".
Capn_Fish
Flite is just text-to-speech, so you just don't get fancy voice effects without it.
climber
Yes, I found the file /opt/native/arm/3.4.6-xscale-softvfp/arm5tel-cakco-linux/lib/lipportaudio.so too but if you view it with ls -la you'll
see it in red colour. So it's not available anymore and obviously a dead link.

Maybe I've to try older or newer version of zgccc. Hopefully I found the file.

If anybody else have time to search for so please do it :-)

Thanks
climber
Jon_J
I found an openzaurus version of libportaudio here, but I get "you don't have permission to access this" message when using a browser in Windows to download it.
http://www.openzaurus.org/feed-browser/?ac...m=libportaudio0

If you can download it, you may be able to extract its contents using "ar"
climber
In the meantime I found the needed lib.

Remove the ending of the file (.ipk) because it's library and not a ipk file.
Copy the file on the zaurus and create a symbolic link to /usr/lib

ln -s /path/to/source/libportaudio.so.0 /usr/lib

ldconfig

That's all and for me it works now :-)


climber
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.