Help - Search - Members - Calendar
Full Version: Hdd1 Error! After Following The Trisoft Restore Instructions
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 Hardware
puckman
Hi Guys.

I have followed the instructions from the TRISoft howto restore HD to the letter but still getting the dreaded HDD1 Error!!

Just to sum up, I wiped the drive, used fdisk to make 3 primary partitions, formated them as instructed, created .sys dir's on hda1 and hda2 and copied the files into them. Still getting a HDD1 Error!!

Can anyone point me in the right direction?
puckman
QUOTE(puckman @ Nov 30 2007, 12:22 AM) *
Hi Guys.

I have followed the instructions from the TRISoft howto restore HD to the letter but still getting the dreaded HDD1 Error!!

Just to sum up, I wiped the drive, used fdisk to make 3 primary partitions, formated them as instructed, created .sys dir's on hda1 and hda2 and copied the files into them. Still getting a HDD1 Error!!

Can anyone point me in the right direction?


I read on one of the threads that pressing CTRL+C+D will bypass the HDD1 Error!! but when I do the Z simply counts from 5 to 0 and reboots.
puckman
QUOTE(puckman @ Nov 30 2007, 01:23 AM) *
QUOTE(puckman @ Nov 30 2007, 12:22 AM) *
Hi Guys.

I have followed the instructions from the TRISoft howto restore HD to the letter but still getting the dreaded HDD1 Error!!

Just to sum up, I wiped the drive, used fdisk to make 3 primary partitions, formated them as instructed, created .sys dir's on hda1 and hda2 and copied the files into them. Still getting a HDD1 Error!!

Can anyone point me in the right direction?


I read on one of the threads that pressing CTRL+C+D will bypass the HDD1 Error!! but when I do the Z simply counts from 5 to 0 and reboots.


I found a GREAT walk trough here: http://figlabs.com/restore/ and now have a fully working Zaurus with original software in Japanese happy.gif

Thought I would put the update here as the above link was not easy to find.
martinbogo
QUOTE(puckman @ Nov 30 2007, 06:41 AM) *
QUOTE(puckman @ Nov 30 2007, 01:23 AM) *
QUOTE(puckman @ Nov 30 2007, 12:22 AM) *
Hi Guys.

I have followed the instructions from the TRISoft howto restore HD to the letter but still getting the dreaded HDD1 Error!!

Just to sum up, I wiped the drive, used fdisk to make 3 primary partitions, formated them as instructed, created .sys dir's on hda1 and hda2 and copied the files into them. Still getting a HDD1 Error!!

Can anyone point me in the right direction?


I read on one of the threads that pressing CTRL+C+D will bypass the HDD1 Error!! but when I do the Z simply counts from 5 to 0 and reboots.


I found a GREAT walk trough here: http://figlabs.com/restore/ and now have a fully working Zaurus with original software in Japanese happy.gif

Thought I would put the update here as the above link was not easy to find.


It is -extremely- important to do the following when formatting the hard disks --- mke2fs -j --- If you do not enable journaling on the filesystem, you will get the HDD Error. If you do not copy the files into a .sys directory on each drive, you will get the HDD error. The Zaurus C3x00 is really picky about this, when using the Cacko/Sharp rom.

So, remember:

First partition (/dev/hda1) is cylinders 1-20 type 83
Second partition (/dev/hda2) is cylinders 21-40 type 83
Third partition (/dev/hda3) is the rest of the drive, type c
Drake01
QUOTE(martinbogo @ Jan 11 2008, 05:22 PM) *
It is -extremely- important to do the following when formatting the hard disks --- mke2fs -j --- If you do not enable journaling on the filesystem, you will get the HDD Error. If you do not copy the files into a .sys directory on each drive, you will get the HDD error. The Zaurus C3x00 is really picky about this, when using the Cacko/Sharp rom.

So, remember:

First partition (/dev/hda1) is cylinders 1-20 type 83
Second partition (/dev/hda2) is cylinders 21-40 type 83
Third partition (/dev/hda3) is the rest of the drive, type c

What if you format ext3? I assume that since ext3 is a journaling fs (I think it's actually just ext2 + journaling) you shouldn't need to do anything additional. Let me know if I'm wrong, because if I am, then I probably fscked up my drive. blink.gif
Barotti
Hi there,

The restoring instructions were very helpful to me, up to a certain point. One odd thing: In my "Spitz" hdc does not exist, but appears to be called hda... OK, so far so good, changing this made repartitioning work, but restoring the hdd image keeps me puzzled.

Executing the last line, starting with gzip -cd /mnt... , I get the error message "no such file or directory". Also here I found a filename difference between "c3000_hdd1.tar.gz" in the instructions and "c3000_hdd1.tar.tar" in the filename. However adapting the filename didn't change anything.
What am I doing wrong? I also tried the Trisoft hdd1 restore from the service menu, but at sector no. 250368 it stops with a read error.

So my C3000 is still dead. Any help is welcome!

Barotti
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.