Help - Search - Members - Calendar
Full Version: Key Repeat Speed
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Debian
dlj0
I vaguely recall being able to set the keyboard repeat speed in either titchy or Angstom. It is too fast for my taste in debian; I'd like to slow it down. Holding a key down even a small fraction of a second (much faster than on my desktop) causes the key to repeat. How do you do that?
2or0
QUOTE(dlj0 @ Dec 4 2007, 07:24 PM) *
I vaguely recall being able to set the keyboard repeat speed in either titchy or Angstom. It is too fast for my taste in debian; I'd like to slow it down. Holding a key down even a small fraction of a second (much faster than on my desktop) causes the key to repeat. How do you do that?


The 'xset' command is useful to change the speed of rate of key.
xset r rate 1000
or change the number if it is too fast or too slow.
dlj0
QUOTE(2or0 @ Dec 5 2007, 05:00 AM) *
QUOTE(dlj0 @ Dec 4 2007, 07:24 PM) *
I vaguely recall being able to set the keyboard repeat speed in either titchy or Angstom. It is too fast for my taste in debian; I'd like to slow it down. Holding a key down even a small fraction of a second (much faster than on my desktop) causes the key to repeat. How do you do that?


The 'xset' command is useful to change the speed of rate of key.
xset r rate 1000
or change the number if it is too fast or too slow.


No joy:

xset r rate 1000
server does not have extension for "r rate" option

This is with debian/eabi (cortez' kernel) and xserver-kdrive-fbdev 1:1.3.0.0-r19 I'd be happy to try another server if someone could suggest one.
jpmatrix
QUOTE(dlj0 @ Dec 5 2007, 03:22 PM) *
No joy:

xset r rate 1000
server does not have extension for "r rate" option

This is with debian/eabi (cortez' kernel) and xserver-kdrive-fbdev 1:1.3.0.0-r19 I'd be happy to try another server if someone could suggest one.


same result for me with angstrom kernel 2.6.23 & zdevil rootfs...

this command should work under X, but is there a non X command too ?
2or0
kdrive doesn't seem to support change of the repeat rate of key. Only I could find the command to turn off key repeat.
In console: setterm -repeat off
in X: xset -r
gojira
some other options would be: using the xorg server (http://www.oesf.org/forum/index.php?showtopic=26362 http://www.oesf.org/forum/index.php?showtopic=25433) adding xkb to kdrive (http://www.oesf.org/forum/index.php?showtopic=26345) or setting it in the kernel (?)

turning autorepeat off completely is better than nothing but it's annoying to lose autorepeat for space delete return and the cursor keys

attached is my script to turn off autorepeat for normal characters but have it on for editing characters
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.