Help - Search - Members - Calendar
Full Version: Google Android On Debian Eabi
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Android
2or0
I tested the google android on my Z. It was successful and promising, but still has a long way to go. If anyone is interested in it, give a try. Now android works on C3100/3200.

The kernel and modules with android system were uploaded on the following place.
http://yonggun.tistory.com/61

Enjoy,
Yonggun
jpmatrix
yeah it looks promising!
and as we can chroot it, it can be executed besides other debian session:)
we should even be able to swap from X to Android,not?

what seems great at first sight is the browser which seems to have builtin java support!
adf
this would be exactly the sort od dual laptop/mobile setup we've been talking about for years.....excellent
jpmatrix
tried so far:

-RotateView applet (must have!) : http://androidzaurus.seesaa.net/article/76612103.html
-google maps ! (OMG ! i could see my house !)
-androitter : http://www.adamrocker.com/blog/174/android...er_client2.html

ZDevil
Thanks again, 2or0! wink.gif

I followed your instructions but start-android ends up with the famous bouncing red ball (the disk LED doesn't flash). Any success story here?

ZDevil
I run into a problem with this Android-patched kernel: the Z refuses to power off. Pressing the power button throws out a lot of messages (going too fast, can't see what they are) and then returns to the prompt. I downloaded and installed the kernel twice and it's the same. Using "shutdown -h now" is fine, though.
2or0
QUOTE(ZDevil @ Jan 7 2008, 07:43 AM) *
I run into a problem with this Android-patched kernel: the Z refuses to power off. Pressing the power button throws out a lot of messages (going too fast, can't see what they are) and then returns to the prompt. I downloaded and installed the kernel twice and it's the same. Using "shutdown -h now" is fine, though.


Now I fixed this problem. You can reflash the kernel which is in my blog.
same
i also see the red ball bounce and nothing more, any fix zdevil? saw you could solve it

thnx
2or0
QUOTE(same @ Jan 9 2008, 02:43 AM) *
i also see the red ball bounce and nothing more, any fix zdevil? saw you could solve it

thnx


In my case, I unloaded the ohci_hcd module when I run android. Please check this is loaded.
same
1st of all, thanx for ur work 2oro =)

i'll try that because i see
CODE
Zaurus:~# lsmod | grep ohci_hcd
ohci_hcd               21252  0
usbcore               123296  2 ohci_hcd


i'm doing apt-get upgrade, when it finishes i'll try removing that smile.gif

EDIT: rmmod ohci_hcd && start-android
it works! thx!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.