Help - Search - Members - Calendar
Full Version: Yet Another Install Image - Testers Wanted!
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Android
Android Zaurus
I build an install image of Android for Angstrom Zaurus.

I test it only on my C3000, and I'm hoping here that it will work on any other Zaurus as long as running on Angstrom and some other 2.6.23 based distributions.

An install image of Android for Angstrom - Testers Wanted!
http://androidzaurus.seesaa.net/article/80102284.html

Feedbacks and contributions are very welcome.

Cheers,
jpmatrix
QUOTE(Android Zaurus @ Jan 22 2008, 12:54 PM) *
I build an install image of Android for Angstrom Zaurus.

I test it only on my C3000, and I'm hoping here that it will work on any other Zaurus as long as running on Angstrom and some other 2.6.23 based distributions.

An install image of Android for Angstrom - Testers Wanted!
http://androidzaurus.seesaa.net/article/80102284.html

Feedbacks and contributions are very welcome.

Cheers,



that sounds great! i'll test it tonight and report here, although i've already got a working android on my c3000 hdd;)
i didn't thought i could put the android rootfs on a sdcard, to be faster and to take no room on the 4GB hdd of the c3000! thanks for that too wink.gif
by the way, my C3000 is debian customized with the Angstrom kernel. so perhaps some people with true angstrom based C3000 would try too
jpmatrix
just tested your android install image : works great without any problem.

wifi internet access : works

thank you!
Android Zaurus
QUOTE(jpmatrix @ Jan 23 2008, 03:08 AM) *
just tested your android install image : works great without any problem.

wifi internet access : works

thank you!


Thank you for testing, jpmatrix.

Your post was very suggesting for me to make it work. I guess you notice HDD LED is less busy now.

A guy told me another C3000 with angstrom-consle-image(2007.1-stable) had no problem.

Cheers,
undrwater
I tried last night on my Tosa, but the Angstrom console image I had had no loop support, so I couldn't mount the android.img.

If there's any way to mount it without loop support, I'd be happy to entertain another option.

I'll be looking for the loop module for Tosa in the meantime.

And in case any Angstrom devs are watching (bugs.openembedded.org is down right now):

The console image works well, except for suspend. Actually suspend works fine the first time, but the second time it hangs with a message about waiting for ac97.

I'll post the exact message when the bugtracker is back up.

Thanks all.
speculatrix
BTW, what should the apt or ipkg sources be? there didn't seem to be any in the c3xxx installable?
thanks
Paul
Android Zaurus
QUOTE(undrwater @ Jan 30 2008, 04:19 AM) *
I tried last night on my Tosa, but the Angstrom console image I had had no loop support, so I couldn't mount the android.img.


I took a look into defconfig-tosa in Angstrom bitbake package and found that loopback device is built as a module.

So, it would be possible you could try to modprobe loop before starting Android.

Thanks,
undrwater
QUOTE(Android Zaurus @ Jan 29 2008, 09:27 PM) *
QUOTE(undrwater @ Jan 30 2008, 04:19 AM) *
I tried last night on my Tosa, but the Angstrom console image I had had no loop support, so I couldn't mount the android.img.


I took a look into defconfig-tosa in Angstrom bitbake package and found that loopback device is built as a module.

So, it would be possible you could try to modprobe loop before starting Android.

Thanks,



Attempted that already...no joy.
Android Zaurus
QUOTE(undrwater @ Jan 30 2008, 02:47 PM) *
Attempted that already...no joy.


I built a loop.ko with my Angstrom-spitz environment. Kernel version is still 2.6.23.

Click to view attachment

I'm not sure it works for you...

Good luck,
xjqian
QUOTE(undrwater @ Jan 29 2008, 01:19 PM) *
The console image works well, except for suspend. Actually suspend works fine the first time, but the second time it hangs with a message about waiting for ac97.

I'll post the exact message when the bugtracker is back up.


you can use http://bugs.openembedded.net/ for now. .org is constantly having dns problem recently. I can confirm the suspend/resume problem you've seen with the 2.6.23 angstrom tosa kernel.

The latest 2.6.24 kernel and suspend/resume issue is being worked on by Dmitry at http://tosa.lumag.spb.ru/news/7/51.html. You can kexec into the zImage provided on the site. If you need more details, we can take our discussion into the tosa forum.

Regards
Gordon
undrwater
Android Zaurus: your loop worked, thanks...but the img wouldn't mount. It worked well enough on my desktop.

It's showing as ext2, but I'm guessing that's not right. Might it work better if I knew the fs?

Nevermind: dmesg states:

CODE
JFFS2 notice: (1020) check_mode_data: wrong data CRC


So maybe my file is corrupt. I'll re-download and try again.

xjqian: I have a few questions I'd like to ask. I'll post a topic in the Tosa forum.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.