Help - Search - Members - Calendar
Full Version: Problem writing on a Samba Share
OESF Forums > General Forums > General Support and Discussion > General Discussion
amdonati
Hi,

I am running TKC ROM and wanted to mount the samba partition in my Z on my linux box.

I have the Z connected through USB, but I set up samba to accept connection from the different interfaces as per the howto on this site.

I then connect with: mount -t smbfs //192.168.129.201/home /home/zaurus

The conncection is established, but read only, no matter if I connect as user or as root!

If I then try to use linneighborhood, I can identify correctly my Z (using the IP address), and the program sees the home share, but when I try to connect as guest, the connection is somehow "lost" and I cannot mount the samba share.

I am a bit confused, I suspect that the problem could be on my linux desktop, but I do not know what to check.

could someone help me here?

Thank you very much!

Adalberto

PS: Under winxp, the file transfer program works well
tumnus
You probably need to specify file permission masks using the smbmount options. I use this myself:

smbmount //192.168.129.201/home /zaurus -o uid=0,gid=100,fmask=0770,dmask=0770
amdonati
Thanks Tumnus for the reply, but It does not work sad.gif

Here is what I did:
CODE
bash-2.05b# smbmount //192.168.129.201/home /mnt/zaurus -o uid=0,gid=100,fmask=0770,dmask=0770

Password:

Anonymous login successful

bash-2.05b# cp /mnt/dati/Documenti/Unzip/Zaurus/romburst /mnt/zaurus/SD_Card/

cp: cannot create regular file `/mnt/zaurus/SD_Card/romburst': No such file or directory


Of course, the romburst file that I tried to copy exists on my desktop!

Maybe it is because I need to log in as guest (I ma using TKCrom 1.0)?
I am a bit confused....

Thanks,
Adalberto
tumnus
Does /mnt/zaurus/SD_Card exist? I would have thought you'd get a permissions error if it is a permissions problem on your PC side, so it may be a permissions problem on your Zaurus.

What format is your SD card?

Try adding the option 'username=root'
amdonati
Well, I have /mnt/zaurus on the desktop, where the whole Z'home dir si mounted.

And of course I can write in /mnt/zaurus, as root (after all, it is a "real" directory! smile.gif ), but the 2 samba shares created in it (MAIN_MEMORY and SD_CARD), can be seen (and I can copy files from there to my desktop), but I cannot wirte in them.

Using username=root did not help.

The SD is ext2 formatted

Adalberto
omega
I seem to have this problem on my c860 with the samba server. I also can't write to /mnt/card (sd) as a user but i can to cf.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.