Help - Search - Members - Calendar
Full Version: Installing Packages
OESF Portables Forum > Model Specific Forums > Sharp Zaurus > Zaurus - pdaXrom
Have tried to install a package using Package Manager. Downloaded the package demo from

...on to my SD card. Loaded up package manager which couldn't see the package on the card so rebooted which sorted that out. Then selected it and it seemed to install but it didn't come back and confirm install was a success. Now the problem is obviously there could be incompatibility issues but no icon has appeared on the desktop or menus so am a bit lost as to whether its worked or not. How do i know if its installed properly and how do i run it and create an icon for it?

First, are you sure that a package from thekompany will install in pdaXrom?
Does the filename look like this? packagename_x.x.x_armv5tel.ipk
The most important thing is armv5tel
If it doesn't have armv5tel, the package is a Sharp/Cacko package or an OZ package, but not for pdaXrom.
The x.x.x is for the version number.

Next if the above is satisfied, there are several reasons why a package doesn't show up in the menu or desktop.
1. It is a console only package. In other words, you need to type the executable into a console to launch it.
2. It has a GUI, but is doesn't have a .desktop file and/or icon.
3. Some packages install into /usr/local/bin/ The menu doesn't "pick up" a lot of these packages.
The menu works best when packages are installed into /usr/bin/
4. The .desktop file or icon are not error-free.

1. First place to look at is the executable filename. It should be in /user/bin/ or /usr/local/bin/
2. In Windows, I use winrar and "examine" the contents of the package. I can find out 3 things this way. The executable filename, the .desktop filename, and the icon filename.
3. Once you have the filename of the executable, you can type it into a console. Your package should run now, unless there are errors, such as missing dependencies (libs mostly), or other errors.
4. If your package launches from the console and appears to be working fine, (there may still be some errors in the console, but some can be ignored), then it is time to look for problems in the .desktop file and/or icon.
Below is an example of a .desktop file from GQview (I removed the non-english stuff). They are located here: /usr/share/applications/
[Desktop Entry]
GenericName=Image Viewer
Comment=View and manage images

In Rox filer, right click on a .desktop file and select "Open as text" to edit it.
If not using Rox filer, use a text editor and navigate to the .desktop file and open it.
What you want to pay attention to are these areas:
Exec=gqview (This does the same thing as typing gqview in a console, it launches the program)
Icon=gqview.png (This points to the icon. In pdaXrom, the icons work best when they are in /usr/share/pixmaps/ )
Categories=Application;Graphics; (This tells the menu system, where to place the icon onto the start menu)

Check for spelling errors, uppercase/lowercase. Find the icon and make sure you can open it in an image viewer/editor. It should be in PNG format, although some are XPM. These should work also.

If no .desktop file exists, you can make a copy of another .desktop file and edit it to point to your newly installed package.
Pick a simple one, like leafpad or gqview. If you don't need languages other than English, delete all the non-English stuff. This makes the .desktop file easier to read.
Then change these lines to point to your executable and icon.
Now to try to make your new package appear in the most appropriate spot on the menu, open a different .desktop file, (which is already located in an appropriate spot on the menu) and copy its "Categories=" section to your new .desktop file.
When you are satisfied with your editing, make sure to select "Save as", and save the desktop file to the exact name as the executable, but with ".desktop" as its extension.

Now close all folders and close your text editor and restart 'X' (use ctrl-alt-backspace) then restart 'X' by typing startx
You need to restart 'X' to enable the menu system to "pick up" your new menu item.
Your new item should now appear on the menu, (and on the desktop if using matchbox/openbox without ROX desktop), if everything is set up properly
First time when I got Z, I bought music player from thekompany ... unfortunately it was for qtopia (sharp or cacko), which means - totally unusable under pdaxrom sad.gif It was nice player
Well the file name is "tkcsoq-c7xx-demo_1.0-040702_arm.ipk" so I guess it will only run in a Sharp/Cacko ROM sad.gif

If this is a decent piece of software I might have to permanently install Cacko as i really need this to work, other option is to use a second pda as there is a pretty decent palm app which does the same thing, rather liked pdaXii13 and was hoping to stick with it.

Want to thank you Jon for your very comprehensive reply smile.gif

QUOTE(kkazakov13 @ Apr 5 2008, 08:28 PM) *
First time when I got Z, I bought music player from thekompany ... unfortunately it was for qtopia (sharp or cacko), which means - totally unusable under pdaxrom sad.gif It was nice player

Do you think their software is good? Unfortunately their forums are shut down because of security problems in phpbbs according to Shawn Gordon of thekompany.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.