I've been running into a couple of problems trying to install or upgrade software that I'm hoping you all can help with. First, I'm using the EABI-armel with a yonggun kernel (188.8.131.52) on an SL-C3200, and have set up to run sid/unstable in my sources (main, contrib, & non-free), plus the repository for some of the debs posted in this forum. And, yes, I've run apt-get update (w/ no error messages), apt-get upgrade, and apt-get dist-upgrade with these repositories in the source.list file.
Problem #1: libts-0.0-0 error
A couple programs I am trying to install have a dependency for version >=1.0 (e.g., XFCE4, which depends on libdirectfb-1.0-0, which in turn depends on libts* >=1.0). When I try to install the appropriate package (libts-0.0-0_1.0-4_armel.deb), either on its own or as a dependency of one of these other programs, I get an error that it is trying to overwrite /usr/lib/ts/collie.so. The error is as follows:
dpkg: error processing /var/cache/apt/archives/libts-0.0-0_1.0-4_armel.deb (--upack):
trying to overwrite '/usr/lib/ts/collie.so', which is also in package libts-1.-0
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
I can try to apt-get -f install (with no package name), but I'm hesitant to do this (seems unsafe) without advice from some more knowledgeable apt/debian folks. The Apt How-to on Debian's site doesn't really address using -f well to relieve my anxiety about running it without indicating a specific package. I've run apt-get -f install libts-0.0-0, but get the same error that I do when I run without the -f flag.
Problem #2: 5 packages that seem to be unable to upgrade without removing some packages I don't think I want removed
There are a number of packages that have available upgrades (e.g., claws-mail, libpng12-0, & pciutils), that don't want to upgrade without removing the following packages: libdirectftb-1.0-0 [interesting given connection to problem #1], libsdl1.2debian, libsdl1.2debian-alsa
links2, & mplayer. I haven't followed the chain of interlocking dependencies to see why this is, but it seems odd that these packages need removed rather than possibly upgraded themselves. Anybody run into something like this? Any advice?
Thanks in advance.