Help - Search - Members - Calendar
Full Version: Setting Up Wifi With Wpa
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Debian
Shoryu
Hi everyone,
i'm running zdevil rootfs and younggun latest kernel on my slc1000, so far everything works great.
The only thing that bugs me is that i don't know how can i enable WPA wifi with this distro.
I've done some research and tried a lot of stuff in /etc/network/interfaces
like using iwpriv wireless-tools commands :
CODE
pre-up iwpriv eth3 set AuthMode=WPAPSK
pre-up iwpriv eth3 set EncrypType=TKIP
pre-up iwpriv eth3 set WPAPSK="mykey"


but set command isn't available.

also using this syntax:
CODE
wireless-key-mgmt WPA-PSK
wireless-key "mykey"

when i try : /etc/init.d/networking restart
i get the error "Set mode" and also "Set Encode" saying that mykey is an invalid argument

i can see my wifi card with iwconfig it's just that it doesn't associate.

my wifi CF card is a Linksys WCF12 which should have WPA support according to some researches on google.
I saw that another tool can do the same as wireless-tools, wpa_supplicant. do i need to install this one or am i missing something here?
I've never had any problems with Wifi using WEP , but never done it with WPA.

thanks for your help smile.gif
mikeones
QUOTE(Shoryu @ May 11 2008, 05:45 PM) *
Hi everyone,
i'm running zdevil rootfs and younggun latest kernel on my slc1000, so far everything works great.
The only thing that bugs me is that i don't know how can i enable WPA wifi with this distro.
I've done some research and tried a lot of stuff in /etc/network/interfaces
like using iwpriv wireless-tools commands :
CODE
pre-up iwpriv eth3 set AuthMode=WPAPSK
pre-up iwpriv eth3 set EncrypType=TKIP
pre-up iwpriv eth3 set WPAPSK="mykey"


but set command isn't available.

also using this syntax:
CODE
wireless-key-mgmt WPA-PSK
wireless-key "mykey"

when i try : /etc/init.d/networking restart
i get the error "Set mode" and also "Set Encode" saying that mykey is an invalid argument

i can see my wifi card with iwconfig it's just that it doesn't associate.

my wifi CF card is a Linksys WCF12 which should have WPA support according to some researches on google.
I saw that another tool can do the same as wireless-tools, wpa_supplicant. do i need to install this one or am i missing something here?
I've never had any problems with Wifi using WEP , but never done it with WPA.

thanks for your help smile.gif

AFAICT, wpa supplicant is not installed. It is required for wireless with wpa.

CODE
apt-get install wpasupplicant
Shoryu
thanks
too bad i can't use apt-get install on the Z since i don't have network working rolleyes.gif .
but i tried to download the different packages manually:
wpasupplicant_0.6.3-1_armel.deb

it has dependencies like:
libpcsclite1_1.4.101-2_armel.deb

and using dpkg -i with this package gave me the errors : unexpected end of file in version number, or : is not a debian format archive

don't know if the dpkg is broken or libpcsclite1_1.4.101-2_armel.deb is corrupted on every mirror i tried blink.gif or there is a problem with my SD card especially with this file laugh.gif

i also need the prism1 driver for this rootfs ...

but i've lost too much time on this (searching info and appropriate packages....) as am i not an expert, so
good luck to everyone who is still trying to make wpa work with zdevil rootfs + younggun kernel. wink.gif
bye
JohnX
If you dual boot, just chroot into your debian install from pdaxrom or angstrom, and apt-get install whatever you need.
For wpa I use the following setup in /etc/network/interfaces:

auto wlan0
iface wlan0 inet dhcp
wpa-ssid My-network
wpa-psk my-long-psk-for-my-network
mikeones
Here is the list of required packages for etch.

http://packages.debian.org/etch/wpasupplicant
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.