Help - Search - Members - Calendar
Full Version: New C1000 Owner Here
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > C1000/3x00 General discussions
I bought a C1000 off eBay last week, and it arrived yesterday. It came with an Ambicom W1100C-CF WIFI card and a PDair leather case for $305.00 (and $10.00 shipping). It is really a nice piece of technology!! It came with Cacko preinstalled, but I flashed a fresh Cacko 1.23 just to have a nice clean start.

First order of business: install the greater than 1 GB SD driver!!! That went well using the ipk from here at the forums.

Things I have learned:

1. Where is the Cacko 1.23 feed? (The one preloaded in the ROM appears to have........ disappeared!) For other new users, here is a feed:
and here is the zaurususergroup feed:

2. The best libSDL to use for scummvm (from the above-referenced feed): . (Other libSDLs seemed to have problems drawing the screen for scummvm properly.)

3. To get samba working: Samba server is already there. You can find smbclient in the feed above. To configure samba, you have to rename the link at /etc/samba/smb.conf to something else and make a copy of it and name the copy smb.conf (leaving it in the same directory). The reason: the original smb.conf is just a simlink to a file that is read-only. So edit the new smb.conf with your own workgroup name, and other settings you wish. Don't forget to: smbd restart and nmbd restart to activate those changes. You may want to edit the /etc/hosts file to include your IP addresses and aliases for other computers on your network too.

4. Where to find the greater than 1 GB SD driver: It is a nice ipk, easy to install! (If you need to unzip it on your Z, go get from the zaurususergroup feed mentioned above. It is a console tool, so just cd to the directory where your zipped file is, and type: unzip [name of zip file] of course without the brackets.)

5. Next came opie-keypebble from the first feed above. You need to enter the IP number of the computer you wish to connect to. At least using the hostname did not work for me. (Maybe because I need to reboot after making the entry in /etc/hosts mentioned in #3 above.)

6. Two more must-haves for me are Zeditor, and TreeExplorer, also in the feeds.

7. Another must-have is EvilJazz's quasar from his website:
(To use with Cacko 1.23, obviously get the one for SharpROM/Cacko. )

Future projects: Can I print from the C1000? and I have not really tried syncing with my laptop yet. Also have not yet tried to use Kismet.

We'll see!!
Something nice to know:

The C1000 uses the same drivers and sync software as the 6000L. So if you are having problems with that Japanese CD, download a copy of the 6000L CD from Sharp:,112,00.html

If you need it, you might want to download it before Sharp decides to remove it from their site.

Disclaimer: I have only used Qtopia Desktop for sync, so I don't know anything about using Intellisync.
Kismet working with Ambicom WL1100C-CF card using Cacko 1.23 ROM.
Looking up forums on this subject, pointed to dead links, so this is not my own work, just a summary of Meanie's instructions using links to the ipks I could find, and changing the kismet.conf to use the Ambicom WL1100C-CF card: Here goes:

Download the following ipks from :


Go to and download:


Go to and download:


Install these ipks and reboot zaurus.

Set up a new network account with the Network app in Settings tab.

Name of account is: "kismet"
In the Config tab, UNcheck the "ANY" box, and name the ESS-ID "any"
Make the network type: "802.11 Ad-Hoc"
On the TCP tab set up the following:
Mask -
On the DNS tab make Primary DNS:

Save this account.
To use the Ambicom wL1100C-CF WIFI card:

Edit /usr/local/etc/kismet.conf, and make sure that:


and in the section "Sources are defined as:" remove the # mark
from in front of the line that says:


There should be a # mark in front of other "source=" lines

Any line that starts with enablesources= can also be commented out,
as all defined sources are enabled by default anyway.

You can also scroll down to the lines that say:
#Do we have a GPS?

and change that second line to:

When you start the Kismet QT program, just set the wireless
card in the "Config" tab to use the "Hostap" scheme. Use the
save button to save that choice and close Kismet QT.
Now start the network card using the kismet account, and after
the taskbar network indicator shows the network card connected,
THEN, start Kismet QT.

That should do it. It did for me!

One more thing: I have found the Ambicom WIFI card to be a bit
flakey at times. So it helps to eject the card and re-insert it,
if you have problems getting it to start between uses.

EDIT: Oh, I forgot, you also need to Click and hold the stylus on the Kismet icon and the Kismet QT icon and check the box to "Execute with root privilege (not secure)".

EDIT 2: This howto is for those using the Cacko 1.23 ROM.
thanks "the_oak" biggrin.gif ,

as an owner of a c1000 and a user of Cacko 1.23 ...these posts are very helpful !
The Ambicom WL1000C-CF WIFI card is a little slow connecting (I have 2 of them, and both are slow, taking 25 seconds or so to connect to my network). They also seem to me to get very warm when in use. dry.gif

So I bought a Symbol LA-4137 off eBay. Drivers for it are built into Cacko 1.23. It connects to my network in 6 seconds!! Great!!! smile.gif But it took me a while to get Kismet working with it. When I connect to the special kismet network account using this card, the taskbar indicator is red, and blinks a message that: "The signal level is low". Here is how to use this card with that kismet network profile, and use it with Kismet QT:

To use the Symbol LA-4137 CF WIFI card, use the "socket" scheme on the Kismet QT config tab. Save and exit Kismet QT.

The kismet.conf file should be the same as for the Abicom WL1000C-CF card. Use the kismet account that you set up in the Network app, and after you connect, you will see that the taskbar network signal indicator is red, and keeps complaining: "The signal level is low". Just go into the konsole and type: "sudo iwconfig wlan0 mode monitor" (without the quotes). Now Kismet QT should work! When you disconnect the network connection, it will revert to regular mode, so you have to type in that mode command each time you reconnect to the kismet network account.

You can make a little script to enable monitor mode, like this:

#! /bin/bash
# this script is to put the Symbol LA-4137 WIFI card into
# monitor mode to use with Kismet.
sudo iwconfig wlan0 mode monitor

I saved the file as /usr/local/etc/symbol_monitor (and made a symlink to it in /home/QtPalmtop/bin). Make the file executable, the owner zaurus, and the group qpe. You can also use the "Tab Setting" app in the "Settings" tab to put a graphical shortcut on the desktop. Just be sure to tap and hold the icon that you create, and uncheck the box for "Display with magnified screen". This keeps the C1000 from darkening the screen, and trying to go into portrait mode.

Now start the kismet network profile, and click on the icon for your script, and watch the red network indicator turn blue.

The icon for symbol_monitor turns into that explosion icon, but everything works. If anyone knows how to keep the explosion icon from happening, I would like to know about that. Also, if there is already an ipk for this that I have not yet found, feel free to show a link to it.
Or, if Cacko uses a shell supporting aliases (I believe it uses Bash, which does), you could do something like:

sudo iwconfig wlan0 mode monitor
kismet $1
sudo iwconfig wlan0 mode managed

alias kismet=/path/to/your/

Your idea is certainly more elegant than my kludged together solution, but I cannot make it work! Not in kismet_qt or in kismet in console. I had to reverse the alias line (command is "alias kismet=/opt/QtPalmtop/bin/kismet" for others who are using the Cacko 1.23 ROM and WIFI card). With my method, kismet_qt works, but not kismet in console.

I think that the problem is kismet.conf calls the hostap drivers (and the console kismet uses kismet.conf). Apparently, kismet_qt has it's own source= line for socket/symbol cards that makes the LA-4137 work. (I can't check this, as kismet_qt is a binary and won't open in a text editor.) Whatever the reason, kismet_qt can use the socket (symbol) driver and kismet can't.

When I use the connect icon in the taskbar, and do a lsmod, I get spectrum_cs, orinoco, and hermes WIFI modules loaded, with only spectrum_cs being used. (If I use the Ambicom card, lsmod tells me that hostap_crypt_wep, hostap_cs, and hostap modules are loaded and all 3 being used.)

My conclusion is that I need a "source=" line for the spectum_cs driver to put in kismet.conf. I've googled and searched these forums and not yet found that line. Can those brighter than me suggest something? If not, kismet_qt works with my work-around, but I think my method is more convoluted than it should be.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.