Help - Search - Members - Calendar
Full Version: C1000 Usb Not Working :(
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 Hardware
evilsocket
Hi guys, first of all sorry for my ugly english XD

I have a Sharp Zaurus SL-C1000, with Cacko ROM 1.23, Qtopia 1.5.4 and kernel 2.4.20 .

Recently i've bought a usb host adapter ( USB A/F to MINI 5p/M ) and tried to connect some usb peripherals such as usb pen drives (vfat formatted, 1GB), usb mouse and so on to my pda, but nothing seems to work sad.gif

i installed the following ipks :

CODE
usb-serial-modules-2.4.20
usb-storage-modules-2.4.20
automounter-c3000_0.4.5
inputhelper_1.0.1-1
ntfs-zaurus_2.4.20


and then typed :

CODE
modprobe usbserial
modprobe usb-storage
modprobe usbmouse
modprobe ntfs


so my lsmod is :

CODE
Module                  Size  Used by
usbmouse                1904   0  (unused)
usb-storage            64400   0  (unused)
scsi_mod               56800   0  [usb-storage]
usbserial              22496   0  (unused)
usbcore                59216   0  [usbmouse usb-storage usbserial]
ntfs                   80976   0  (unused)
registers              52288   0  (unused)
pxa_bi                 24848   0  (unused)
net_fd                 25248   0  (unused)
usbdcore               35504   0  [pxa_bi net_fd]
usbdmonitor             5488   0
usb-monitor             6496   0
hostap_crypt_wep        3600   1
hostap_cs              48464   2
hostap                 97216   0  [hostap_crypt_wep hostap_cs]
sharp_mmcsd_m          41088   2
bvdd                   11136   0  (unused)


and relative dmesg :

CODE
NTFS driver 2.1.2a [Flags: R/O MODULE].
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb.c: registered new driver serial
usbserial.c: USB Serial support registered for Generic
usbserial.c: USB Serial Driver core v1.4
SCSI subsystem driver Revision: 1.00
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
usb.c: registered new driver usb_mouse
usbmouse.c: v1.6:USB HID Boot Protocol mouse driver


nothing works anyway ... any hint ?
deluxe
QUOTE(evilsocket @ May 16 2008, 06:50 AM) *
Hi guys, first of all sorry for my ugly english XD

I have a Sharp Zaurus SL-C1000, with Cacko ROM 1.23, Qtopia 1.5.4 and kernel 2.4.20 .

Recently i've bought a usb host adapter ( USB A/F to MINI 5p/M ) and tried to connect some usb peripherals such as usb pen drives (vfat formatted, 1GB), usb mouse and so on to my pda, but nothing seems to work sad.gif

i installed the following ipks :

CODE
usb-serial-modules-2.4.20
usb-storage-modules-2.4.20
automounter-c3000_0.4.5
inputhelper_1.0.1-1
ntfs-zaurus_2.4.20


and then typed :

CODE
modprobe usbserial
modprobe usb-storage
modprobe usbmouse
modprobe ntfs


so my lsmod is :

CODE
Module                  Size  Used by
usbmouse                1904   0  (unused)
usb-storage            64400   0  (unused)
scsi_mod               56800   0  [usb-storage]
usbserial              22496   0  (unused)
usbcore                59216   0  [usbmouse usb-storage usbserial]
ntfs                   80976   0  (unused)
registers              52288   0  (unused)
pxa_bi                 24848   0  (unused)
net_fd                 25248   0  (unused)
usbdcore               35504   0  [pxa_bi net_fd]
usbdmonitor             5488   0
usb-monitor             6496   0
hostap_crypt_wep        3600   1
hostap_cs              48464   2
hostap                 97216   0  [hostap_crypt_wep hostap_cs]
sharp_mmcsd_m          41088   2
bvdd                   11136   0  (unused)


and relative dmesg :

CODE
NTFS driver 2.1.2a [Flags: R/O MODULE].
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb.c: registered new driver serial
usbserial.c: USB Serial support registered for Generic
usbserial.c: USB Serial Driver core v1.4
SCSI subsystem driver Revision: 1.00
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
usb.c: registered new driver usb_mouse
usbmouse.c: v1.6:USB HID Boot Protocol mouse driver


nothing works anyway ... any hint ?



Well, I have the exact same zaurus, running the exact same ROM (Cacko, heavy), and USB works fine. The ROM supports USB without the need to add *any* software, maybe your cable is faulty or your attached devices require more power than the zaurus can provide via usb?? If that's the case, you'll need a powered hub.
evilsocket
ok ill try a powered hub, thanks wink.gif
pwyll
QUOTE(evilsocket @ May 16 2008, 09:14 AM) *
ok ill try a powered hub, thanks wink.gif



If the powered hub doesn't work, you could try removing the ipks. I've not *used* Cacko, but on both pdaXii13 and Debian I have no problem plugging in a USB "travel" mouse, full-sized USB keyboard or reading/writing to a 2gig USB flash memory stick with my C1000. I do need a powered hub for anything else, but if a USB mouse won't work (after trying the powered hub) I'd look at the cable or at the Z's internals.


Scott

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.