Help - Search - Members - Calendar
Full Version: Wpa Howto?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
ckblackm
Does anyone have a step-by-step guide for getting wpa running under pdaXrom?
I've got a SL-3200, D-Link DCF-660W, and am running beta3. (actually... it's Daniels weeXpc.. but it's based off beta3.)

thanks,
Christopher.
Capn_Fish
It's simple:

CODE
wpa_passphrase YOUR_SSID YOUR_PASSPHRASE > /etc/wpa_supplicant.conf


If you're using WPA2/AES, it should loook something like this:

CODE
network={
ssid="YOUR_SSID"
key_mgmt=WPA-PSK
proto=RSN
group=CCMP
pairwise=CCMP
psk=(lots of gibberish)
}


(You have to add some lines yourself)

If you're using TKIP, the pairwise, proto, and/or group lines will be different, but I can't remember how ATM. They may not even be necessary.

I've also had issues connecting to a non-SSID-broadcasting network, so you may have to change that.

HTH
stupkid
Well on pdaXii13 I had to make several changes to the pcmcia network scripts to get it working to my satisfaction. I think the scripts were updated properly in the newer versions of pdaXrom. I can post my diffs if it helps anyone.
kkazakov13
QUOTE(stupkid @ May 29 2008, 11:34 PM) *
Well on pdaXii13 I had to make several changes to the pcmcia network scripts to get it working to my satisfaction. I think the scripts were updated properly in the newer versions of pdaXrom. I can post my diffs if it helps anyone.



Do it, please. I'm running a script each time I want connection and I don't have time to play with this by myself
stupkid
Sorry for the late reply. Well I seem to have lost the original versions from pdaxii13, but here are the three files I changed

/etc/pcmcia/network
/etc/pcmcia/wireless
/etc/pcmcia/wireless.opts

These new scripts add new values that you can use in the wireless.opts options, examples are included. You specify WPA=y to use WPA and WPADRIVER to specify a drive or I default to hostap. You setup your /etc/wpa_supplicant.conf as usual. For reference my home net, which uses WPA-PSK2, looks something like this:

network={
ssid="MyHomeNetwork"
scan_ssid=1
key_mgmt=WPA-PSK
proto=WPA
pairwise=CCMP TKIP
group=CCMP TKIP
psk="abcdefghijklmnopqrstuvwxyz"
}

With these scripts you should only need to setup the /etc/wpa_supplicant.conf and then add the necessary stanza to the wireless.opts for your network and you should be golden. All I have to do is change schemes with cardctl (ex. cardctl -f Home) and I can switch configs and even different wpa_supplicant.conf entries.

Hope this helps!Click to view attachment
kkazakov13
Thanks, will check asap (tomorrow) and let you know if it's okay smile.gif if it works, I can include it in my patched system to b3
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.