Help - Search - Members - Calendar
Full Version: NoMachine NX Client for Zaurus
OESF Portables Forum > General Forums > General Discussion
ZeeUser
I was looking for alternatives to plain old VNC the other day and I came across the NoMachine NX Client for Zaurus . Needless to say, the features of this app have perked my interest! However, I have not been able to get it to install from either the Package Manager or the command line... It either requires OpenZaurus or at least some of the packages from it (see this). Also, it is only stated as being compatable with the 5XXX series. I know that most software for the 5XXX series is compatable with the C-series, but I am not going through the trouble of installing an unstable ROM for one app that may or may not work.

I am not a technical user, so I cannot look much further into this matter. I was wondering, though, if anyone has used this software on the Zaurus and what their experiences have been. Has anyone gotten this app to work on the C-series? If so, were you using OpenZaurus or did you just install some OZ packages to your Sharp-based ROM (and if so, which ones)? Otherwise, are there any comparable apps available for the Sharp-based or Cacko X11 ROM?

The only way I have found, as a non-paying user, to contact someone with NoMachine is to post in their mailing lists. However, I think it would be best if someone who has a better knowledge of the technical aspects than I do would contact them (I will contact them if no one else does so by next Monday).

Thanks in advance for any and all help!
lardman
It will be a Qtopia app.

Might be in ar format rather than tar.gz. Try 'ar -x packagename.ipk', then tar.gz the resultant files, try again.

Try running it from the command line to see what libs it complains about not having. I assume it would run on a C machine (with Qtopia embedded, not inside X11)

Si
slocaus
It is installed and works fine on my 5500 with tkcROM 1.0. It sure appears to be a standard Qtopia app, since it installed with the Software app. <shrug>
agosine
slocaus - Since you have it installed can you give me a bit of info as to what you can use it for? I looked into it, but wasn't sure if it could be used within a server on the other end.
slocaus
You need a server to connect. I use it to connect and get files from my home computer when I am out of town via NPC and cellphone connect at 14.4k. Works great. I bought the server app for my linux box.
dz
i use nomachine's software.. got the server set up on my linux box, and a client on my windows.. i couldn't get it to work on my 5600, so i just stopped trying
stupkid
The install path for most of the binaries is /usr/NX, which causes problems when you have a read only loop back file system for /usr. I manually installed my SD card and the apps launched, but I don't have a server to test against at the moment. I have attached the file.

Enjoy.
agosine
stupkid - I tried your file but it gives me an error during install. The icon is there afterwards, but never runs.
stupkid
That is because the /usr file system is a read-only loop back file system. You will have better success running it on a Compact Flash or SD memory card. When I have some time to tinker with creating a link under /usr I'll post the solution. Until then it won't work installed to internal flash. Sorry NoMachine should have built a nicer package. sad.gif
ZeeUser
stupkid:
How exactly do I install the. ipk to a memory card? When I try it through Package Manager, it gives me the following error:
"This package is available only for main memory. Please install it in main memory"
I am a noob to Linux and the console, but I tried the following anyways:
"ipkg -d /mnt/card/nxclient install /mnt/card/nxembedded-zaurus_arm.ipk" and got a bunch of "cannot create symlink, operation not permitted" errors
stupkid
Ugh! Sorry folks, this is going to be more work than I originally thought. There are some OZ things that are being called in the shell scripts for this package specifically start-stop-daemon and opie. It will take some additional work to get it usable. Give me a few more hours for testing.
ZeeUser
QUOTE
Ugh!  Sorry folks, this is going to be more work than I originally thought.  There are some OZ things that are being called in the shell scripts for this package specifically start-stop-daemon and opie.  It will take some additional work to get it usable.  Give me a few more hours for testing.
That's ok. Thanks for working on this!
stupkid
Here ya go. This package will install and launch, but the app is not sane. It does not connect to the port specified in the configs. It continually connects to Port 22. Oh well, if someone gets this thing to work right please post how. Users of non C series Z's should change the line in /usr/local/NX/bin/x to read:

/usr/local/NX/bin/NXfbdev -terminate -screen 240x320@270 -dpi 100 -mouse /dev/ets

Download:

http://www.bryandeluca.com/nxembedded-zaurus_arm.ipk

Enjoy.
agosine
stupkid - Thanks for all your work on this. The package installs without issue now except that it says there are missing dependences. Only issue now is trying to run it. I get the following error after the login window.

Error: Cannot open NX transport library 'libXcomp.so.1.2.2'. Error is 'libz.so.1: cannot load shared object file: No such file or directory'.
ZeeUser
Stupkid:
I installed your .ipk without any errors. Good job!

You can actually test drive the client with a test server that NoMachine has set up: http://www.nomachine.com/testdrive.php . You should receive the login info immediately.... Also, I noticed that the port for the test drive server is 22. I don't know the technical details of why you wanted to change the port number in the config file, but there is a port field in the Config settings.

Here is what occurs when I try to connect to the test server, though:
Info: NXPROXY version 1.2.2 running in SERVER mode.
Info: Using process mode with pid '1572'.
Info: Connecting to remote host 'testdrive.nomachine.com:5184' on SSH port 'localhost:1044'.
Info: Connection to remote proxy 'testdrive.nomachine.com:5184' established.
Info: Handshaking with remote proxy 'testdrive.nomachine.com:5184' completed.
Info: Synchronizing local and remote caches.
Info: Using cache parameters 4/262144/256KB/256KB.
Info: Using wan link parameters 16384/80/16/8192.
Info: Using preferred pack method 16m-jpeg-9.
Info: Using ZLIB data compression level 1.
Info: Using ZLIB data threshold set to 32.
Info: Not using ZLIB stream compression.
Info: Using remote ZLIB data compression level 1.
Info: Not using remote ZLIB stream compression.
Info: No suitable cache file found.
Info: Using remote server 'testdrive.nomachine.com:5184'.
Info: Forwarding embedded keyboard connections to port '6000'.
Info: Starting X protocol compression.
Error: Connection to '127.0.0.1:0' failed. Error is 111 'Connection refused'.

I triple-checked all the settings, and tried connecting four times, all with the same error. I don't expect you to do tech support for NoMachine's software, but before I contact them I was wondering if any of the changes you made may be causing this error (why is the client trying to connect to 127.0.0.1?)
Thanks again!
slocaus
127.0.0.1 is localhost, which is your Zaurus. It sounds like the nomachine sever is rejecting your connection to it.
stupkid
ZeeUser:

I only made changes to the shell scripts that start the apps. Those are:

/opt/QtPalmtop/bin/nxclient
/usr/local/NX/bin/x

I think that you want to change the DISPLAY value in the /usr/local/NX/bin/x script.

agosine:

You should be starting the nxclient from /opt/QtPalmtop/bin/nxclient, which will set the path to the NX libraries. If you are running this script and you did not install onto your internal flash then you will need to change the paths to /usr/local/NX/lib to whereever you installed (example: /mnt/cf/usr/local/NX/lib).

What did I get myself into... wink.gif
stupkid
ZeeUser:

I agree with slocaus. It should be launching NXfbdev, which I can only assume is some kind of X windows like server . The original scripts killed opie and then started NXfbdev. I need to learn a bit more about how to do this in QPE.

agosine:

In addition to not having the LD_LIBRARY_PATH set from the nxclient script it also looks like you do not have zlib installed. You can get zlib for sharp here:

http://prdownloads.sourceforge.net/zaurus/...e_mirror=heanet

That should be a package dependancy.
ZeeUser
Stupkid:
So are we basically out of luck for now? :cry: I just wanted to know so I don't keep messing with it for nothing...
Thanks!
ZeeUser
I put a request in for some help on the NoMachine nxusers mailing list, and got this response:

drobrien01 wrote:
> These notes might also be of help:
> Stupkid wrote:
> "...It should be launching NXfbdev, which I can only assume is some kind
> of X windows like server . The original scripts killed opie and then
> started NXfbdev. I need to learn a bit more about how to do this in QPE..."

Basically we need a X server running on QPE. NXfbdev is
just that. There were technical limitations which prevented
NXfbdev to run on QPE, that's why we only provided NX for
OpenZaurus.

> an X11 > port of the NX Zaurus Client would be even better (see
> http://www.pdaxrom.org/ )

This is certainly interesting. Did you try to run the GPLed
nxcompsh/nxrun command line client on it?

/Gian Filippo.


So I think we really are out of luck as far as Qtopia goes, unless someone is willing to resolve whatever technical limitations there are... On the plus side, there is hope for the NX Client on X11. Anyone using the Cacko X11 ROM care to work with us on this?
stupkid
Hmm, I wonder if Xqt would work? http://xqt.sourceforge.jp/ maybe we CAN fit the square peg in the round hole if we get a different mallet.
ZeeUser
Stupkid:
I don't know how to compile anything :roll:
The sources are here if you would like to try, though.
ZeeUser
Anyways, I did test drive the NX Client for Windows for a few minutes, and was quite impressed with the speed! Even a game of Asteroids was playable, with only the occasional lag. Mind you this was over a 3 megabit cable internet connection, but impressive nonetheless. I'm sure it would run smooth as silk at 640x480 and over the wireless LAN (which is mostly what I'll be using it over)
ZeeUser
Stupkid,
Did you ever try to get the NX client to run under X/Qt? If so, what were your results? LordDavon was working on getting the NX client to run under pdaXrom. Last I heard from him he was working on optimizing it for the ATI graphics chipset and X-scale (so I assume he got it working). However, I have not heard from him in over two weeks now.... He also mentioned the Sash was interested in the project, so I may try contacting him.
BalroG
Hi!

Does anybody have Stupkid's ipk as mentioned above? The link to the file is broken - going to the main page also didn't help.

ZeeUser, Stupkid is the file mirrored somewhere?

Thanks!!
BalroG
OOPS, aplogies, didn't see that I was on page 1 of 2, sorry.

Anyway, did this ever work?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.