Help - Search - Members - Calendar
Full Version: Sl-c3200 : Ambicom Wl1100c Card, Telnet-over-usb Dont Work
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > C1000/3x00 General discussions

My apologies if these questions have been asked before.

I just acquired a Zaurus SL-C3200 from Conics (Thanks, Brett!). It has the default Sharp ROM. ROM version is 1.02 JP. English conversion was done by Conics.

I am facing 2 problems:

1. When I insert an Ambicom WL1100C-CF card, the card is recognised and the little globe icon appears. However, the little light on the card itself does not turn on. When I try to connect to a network, it fails.
I tried the card on a Sigmarion III running WinCE4.1, and after installing drivers, the card worked fine.

2. I am using Win2K. I followed Trisoft's instructions from here for the sync installation. I used the USBDrivers/Network directory from the Sharp CDROM for the drivers. Drivers were installed, and when I plugged the Zaurus in, it was recognised. The NDIS driver shows up in Device Manager.

However, as per the instructions, when I try to telnet to the device, or ping it, it fails.

Am I doing something wrong ? Or is there a systematic issue that causes both problems ?
Please help!

For the Wi-Fi card, you may want to make sure the HostAP drivers are loaded and not Orinoco. Do a:


in the terminal, and look to see if "hostap" and "hostap_cs" are present. If "orinoco" and "orinoco_cs" are, do a:

rmmod orinoco_cs
rmmod orinoco


modprobe hostap
modprobe hostap_cs

and you should be good.

USB networking info later.
Thanks for the quick reply, Capn_Fish.

When I do lsmod, I only see prism2_cs and p80211. I do not see either orinoco or hostap.
Doing "modprobe hostap" gives me a "Can't locate module" error.

Do I need to get this module from somewhere and install before it works ?


QUOTE(Capn_Fish @ Jul 2 2008, 10:17 AM) *
For the Wi-Fi card, you may want to make sure the HostAP drivers are loaded and not Orinoco. Do a:


USB networking info later.
Hmm....I would think it's already installed. I guess you'll have to wait for somebody with more knowledge in the area.

For USB networking, on Linux it's as easy as "ifconfig usb0 up" At least with Debian (on the Zaurus), I've found I need to fiddle with my firewall to get it to work. You could try turning yours off for a moment and see if that helps.
If you care to, flashing with Cacko is quick, it simply works, and the Ambicom card is then plug and play.
Why do I always assume that people don't want to change distros?
For the wifi, have you set up the network in the network app correctly, witth ssid and wep key (if necessary)? Just checking the obvious before trying to troubleshoot.
I'll try the USB networking idea now. And sure, I would be open to changing distros!

Yes, I can flash the ROM, but is there somewhere I would get detailed instructions on how to do this ? And is there a way to backup the entire Sharp ROM before flashing Cacko ? And where would I get the latest version of Cacko ?

I rechecked my wifi settings - they all seem to be correct.

Thanks everyone for the help so far!
Flashing Cacko is insanely easy:

-Download the files: (somewhere on Tyrannozaurus, still looking)

-Backup your Z to a FAT16 SD/CF card (only have one card in the Z):
--remove battery and AC
--hold D and M
--insert AC
--find the "nand backup" option
--select it
--copy the SYSC320.DBK file to somewhere safe

-Extract the files to the root of the SD card

-Insert SD into the Z

-Remove all power again

-Insert battery and AC

-Hold OK, then hit the power switch. You should have a Japanese menu

-Chooses option 4 (flash)

-Say "Y" to the warning

-Choose SD/CF, whichever you're using

-Choose the "flash" option

-Reboot into Cacko.

I hope that was clear enough.

EDIT: Wow, that was unnecessary:

There's all you need!

(Full version has lots of stuff that can't be removed, more stuff "just works," Lite is Full with stuff taken out that you can reinstall at will).
I installed Cacko after backing up the Sharp distro, and now the Ambicom works and I am able to connect to the internet. Thanks very much!

About the Usb-over-telnet, there are some things at MyZaurus that I will try before I report any progress on that.

And now of course I have more questions!

Has anyone tried a Cisco VPN client like vpnc on Cacko ? I downloaded and installed a vpnc ipk from the above link, but it doesn't work - complains about being missing. So I was wondering if anyone has built a VPN client and VNC viewer for the Cacko distro ?

It looks like the VNC viewer for Cacko is called "keypebble." No idea about VPN, but if it's a CLI app, one from the pdaX Beta 1 feed should work.
I installed your suggested VNC viewer. And I downloaded the ipks and followed the instructions at Viperin-Z to install vpnc along with a little system applet to configure vpnc.
Now everything works and I can connect to my corporate network!
Thanks very much, Capn_fish!

I see that Cacko doesn't recognise SDHC cards - I tried a 4GB Sandisk SDHC card - so that limits me to the 2GB SD card, right ?

Also, the USB-over-telnet doesn't quite work yet. I am able to ping the PC from the Zaurus having followed the instructions from the MyZaurus link above, but ping/telnet from the PC to the Zaurus does not work yet.

Glad to have helped.

It's true that Cacko can't use SDHC cards. You're not limited to 2 GB, though, just to SD cards (that occasionally go up to 4 GB). Note that this is only possible if you have the updated driver (I assume you do).

I can't really help you with the USB thing unless you're on Linux. Sorry.
The updated SD driver in question is sdmmc-module_2.4.20_arm.ipk ? Yes, I installed that. I'll look around for a 4GB card that's SD-only.

If I figure out the PC-to-Zaurus USB connection problem, I'll post it here.

Thanks for everything!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.