Help - Search - Members - Calendar
Full Version: Qtopia 4.x On Hp Ipaq 6300 (6365) Series
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > iPAQ Forum
timematcher
Hi all...!

I dont know whether its a right question to ask herein this forum...but...anyways..
@Mods Kindly move it to the right place if it is in a wrong forum...

All i want is to run qtopia on HP IPAQ 6365.

I compiled Qtopia Open Source 4.2.x and ran it HP IPAQ 6365.
(I can provide the details if somebody wants but i have a different query right now..!)

Qtopia PIM runs on it with most of the Devices DISABLED...!

Camera Application ----says cant find Camera...
Call Application ------ "No Modem". sad.gif
Sim Application ----- says that "Sim not inserted" althougjh sim is there.
Audio and Media Player ----- No sound is there. I havent checked a video...! huh.gif sad.gif

I compiled qtopia with phone and phonevendor option enabled set to "wavecomm" as Wismo Pac P5186 Wavecomm GSM Module is there in HP IPAQ 6365.

I have tried to disable "Multiplexer" option as well at runtime to check whether the GSM Module works or not.

My main Goal is to make the GSM Module detect the network, read sim, send and receive messages and calls but the GSM Modem is not detected and the main Qtopia screen says "No modem" on Qtopia PIM Startup.

Qtopia Opensource has a built-in driver for Wavecomm. But either it doesnt work or i am doing something wrong....!

Can anybody help help in this regard???

I started this work as my Term Project and i must complete it.

Any reply is highly appreciated.

Thanks
timematcher
hI
i Just added/edited the folllowing lines...

export QTOPIA_PHONE_VENDOR="wavecom"
export QTOPIA_PHONE_MUX=no
export QTOPIA_PHONE_DEVICE="/dev/ttyS1:115200"


and then i run

$QPEDIR/bin/qpe -terminal 3 ##The 'terminal' doesnt change anything

Now the problem is it says "Please Wait" on the main screen. And keeps on waiting..! huh.gif

If i change the last line.....

export QTOPIA_PHONE_DEVICE="/dev/null:115200"



It again says "No Modem" dry.gif

I am really stuck on it ....

If you guys out there, come and read this post and dont know the solution then there might be a chance that you know this..

Is there is a device that is similar in architecture/GSM operation to HP IPAQ 6315 having a working Qtopia-based distro?

Any Reply will be highly appreciated...!

Thanks a lot....

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.