Help - Search - Members - Calendar
Full Version: Problem Loading Hh Bl - Reset Not Recognised
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > SIMpad forum
d2a
in the past i've managed to install previous versions of the bootloader, but always reverted to the siemens one because of the instability of early linux builds. wanted to try the new build, so followed instructions: erased flash memory via terminal. then closed terminal and ran serload blupdater.img. prompted to reset, but no response from serload when i do. tried all combinations of reset plus button and nothing seems to register. now just get the tartan screen obviously.

simpad connected to windows xp machine, bootloader is siemens 2.5.3, old OS was CE 4.1

any ideas?
mr_nice
This sounds like you have forgotten to change the serial speed settings for bootldr.
The settings for bootldr are:
"As connection settings you should use 115200 baud 8 databits no parity 1 stopbit (115200 8N1), no hardware and no software flow control."
regards
mr nice
d2a
hmm - well, that isn't strictly accurate. in order to view the monitor menu and therefore erase flash, the terminal settings need to be 38400 8N1

this is the output of the terminal using those settings:

QUOTE
PBL V2.4 20.07.2001
Booting...
================================================
Siemens Switzerland Bootloader V2.5.3 10.06.2003
Running @206Mhz Processor ID 0x6901b118
Press ESC for monitor
Occupied Memory: [0x00004000-0x00008000],[0x00008014-0x0007500c]
Flash Id 0x00000018 at virt adr 0x05000000 Size 0x01000000
No 32Bit Flash detected 0x00000000
FlashImage Checksum 0x05040014-0x05059f11=0x8912ac03 Bootloader Image OK
Fabdata Flash @0x05059f18 Ram @0x00021f18 FABDATA: S842-KJGCA
MQ200 - Revision ID=2 ...
Initialise PCMCIA Interface... done.
Codec UCB1200 ID:0x1005 Ver.5 Dev.0 Suppl.1 IO 0x00000000
No PCMCIA Card Attached
NO PCMCIA CARD! -- Use serial IO
Sysinit done
No serial download request
Boothdr at 0x05080000 -> 0xffffffff
Calling Monitor

=====================
Monitor:
=====================
Boot from Flash 'f'
Boot from Net 'n'
Power Off 'o'
Erase PSM+Registry'p'
Exit 'q'
Erase Registry 'r'
Erase Flash 'y'
Soft Reset 's'
Print Fab-String 'w'
->


i enter y to erase flash which then shows the ascii progress bar. when this completes i disconnect the terminal, and try the serload blupdater.img in a dos prompt, which then displays the prompt to reset. however when i reset, there is no response and the fact i've reset the device is not recognised.

is there a setting in the bios that might effect this? i will try using a different (linux) box
d2a
a ha - tried using my old linux box and it worked straight off. must be something wrong with my XP box. serial download in progress - fingers crossed it all works out. thanks for the reply anyway.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.