Help - Search - Members - Calendar
Full Version: Angstrom Install - My Experience
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > SIMpad forum
So - after a minor glitch with a strange serial port problem, I had no problem installing the bootloader. I then downloaded the X11 image and copied it onto a compact flash card. Following the instructions I renamed the jffs2 file, inserted it into the simpad, connected a terminal via serial and reset the simpad.

however, reading the final page of the bootloader instructions, and watching the output of the terminal, it seems the bootloader is looking for a differently named image, and would automatically install without the need for the terminal, if it was correctly named.

i then continued as instructed, i.e. "copy hda1:/rootfs.jffs2 root" and the install completed. i then booted into angstrom.

  • the touch screen seems slightly inaccurate, especially noticeable within the virtual keyboard. recalibration improved this slightly
  • virtual keyboard (ol' good keyboard - qwertyGB geometry layout) seems to misbehave - various keys sometimes behave as if the enter key had been pressed - d especially. this happens within terminal.
  • virtual keyboard size - would be nice if the keyboard width was parametric, so something like original small CE keyboard could be displayed
  • Keys and Buttons setup - no button configuration available for this device - would be good to have the hardware buttons mappable, to enable the keyboard button, right click, and change the behaviour of the 4 way switch.
  • Battery monitor - does not seem to reflect battery status when on battery - if charging (connected to mains) battery juice is accurately shown as 64% for instance, but once unplugged, battery status jumps to 100%, and never drops until device goes flat and powers down
  • WiFi - tried three wlan pcmcia cards - only one worked. three cards are
    • siemens i-gate 11m - works natively under CE but fails to init "cs: pcmcia_socket0: time out after reset."
    • Xircom CWE1100 - fails to init "cs: pcmcia_socket0: time out after reset."
    • Linksys WPC11 ver.3 - plug and play
  • Wireless monitor panel utility - does not reflect status of wifi card
All in all, not too bad. Only other issue thus far is the lack of space - really cramped, so not been able to install anything laugh.gif
Hi d2a,

thank you for testing this image and sorry for errors inside.

siemens i-gate 11m and similar should work with newer autobuilder
images from
current ->

not all modules are inside, the missing shoud be ->

the status from battery should work for sl4/slc without problems
-> xterm-console:
cat /sys/class/ucb1x00/ucb1x00/vbatt (gives voltage of battery)
cat /sys/class/ucb1x00/ucb1x00/vcharger (gives voltage from charger if present)
cat /sys/class/ucb1x00/ucb1x00/icharger (gives "current" while charging, smaller values [28] show battery fully loaded)


apm (gives status of charger present, battery status - capacity - estimated runtime simple)

small flash space is a real problem, i recommande mmc/sd-card mod ;-)
i use 1gb mmc+ and space is no more a problem for me

virtual keyb: please test en_GB.qwertytabletpc , with this, touchscreen should be no problem

wireless monitor panel utility comes with matchbox, i have no answer for that error yet

hey no problem - this thing (angstrom on a simpad) is still brilliant, and much more stable and mature than when i last tried a linux image a few years back. well done on all the hard work and let me know if i can help out with any testing.

the battery: sim is not plugged in and has been running for at least 60 minutes. apm returns Off-line, battery charging,: 100% (4:00:00). when ac power plug inserted, apm returns On-line, battery charging: 5% (0:12:00)

so battery monitor is accurately reporting apm values, but apm values are wrong when ac not present. vbatt values change as battery goes flat and during charging, so vbatt reporting accurately but for some reason apm not using value.

i am using the tabletpc layout and this is a significant improvement but still suffers from occasional virtual typing - i.e. the key clicked is not the key registered.

i will definitely investigate the sd card mod - time to get the soldering iron out...
@mrdata hi - nice to reed you smile.gif


Which release version did you install and which firmware has your igate card?
If you want to help you can allways look at the unstable images and test them.

The battery stuff will change for later kernels >2.6.24 because it is broken there anyway.

You can also try to gain more space with killing your /home parition [1]

best regards
mr nice

Which release version did you install...

I installed the 2007.12 r14 - Angstrom-x11-image-glibc-ipk-2007.12-r14-simpad.rootfs.jffs2

...and which firmware has your igate card?

not sure i know how to get that with it not working on the simpad - any way of finding out from serial numbers etc or via CE?

If you want to help you can allways look at the unstable images and test them.

will do - may try one tonight

The battery stuff will change for later kernels >2.6.24 because it is broken there anyway.

ok - thanks for the info
If you own a laptop you can check the firmware version with:
"hostap_diag wlan0"
i-gate firmware - plugged my igate card into my pundit to find out the firmware version - dmesg reports:

Intersil firmware earlier than v0.8.x - several features not supported
Firmware determined as Intersil 0.7.6

So I'm a bit out of date apparently wink.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.