Help - Search - Members - Calendar
Full Version: Mail Problems
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > OpenBSD
BJIce
Hi,
I have this strange problem:
when I try to send mail via [ksh] shell on my OpenBSD 4.0 server there is no problem and mail is delivered, but when I try to send email via php with function mail() it return false and the mail is not sended.

I have readed everthing I can find about this problem but nothing seems to work.

I'm set my php.ini to use exacty the same sendmail I'm using when I send email via shell.

So if anyone had same problem and solved it, please tell me how to manage this.

Thanks in advance.
desertrat
QUOTE(BJIce @ Sep 15 2008, 02:09 PM) *
when I try to send mail via [ksh] shell on my OpenBSD 4.0 server there is no problem and mail is delivered, but when I try to send email via php with function mail() it return false and the mail is not sended.
When sending using php does the mail ever make it into the mail queue? Look at your mail logs to see whether mail is injected or not.

QUOTE
I'm set my php.ini to use exacty the same sendmail I'm using when I send email via shell.
How did you compile php? If at the time of compilation php doesn't find an appropriate sendmail it will compiled without mail support - however I'm not sure whether the mail() function is still available (but fails silently) or not.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.