Help - Search - Members - Calendar
Full Version: Mplayer Full Screen Configuration
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
xcraft
I'm using Angstrom Console version to have a long battery life while listening music and watching videos. I noticed that when i try to see a video in full screen mode with mplayer, it doesnt make it full screen, it just places the video to the middle of the screen with a black border. i tried -zoom or -fs but they dont work. I've googled and found out that i should use -vo x11 but while i installed console version it doesnt support x11. My questions are ...
1- Is there any other way to watch the videos full screen?
2- Do i have to change to Angstrom X11?
3- Can i just install x11 libs and use "-vo x11"?
Thank you
utx
QUOTE(xcraft @ Oct 21 2008, 08:45 AM) *
1- Is there any other way to watch the videos full screen?


-fs. Bus is probably not fast enough to transfer 640x480. For 320x240 it is sufficient, so you have to scale video down and use -vm. It works ony for -vo pxa.

QUOTE(xcraft @ Oct 21 2008, 08:45 AM) *
2- Do i have to change to Angstrom X11?


No, you van use -vo sdl, -vo fbdev or -vo pxa.

QUOTE(xcraft @ Oct 21 2008, 08:45 AM) *
3- Can i just install x11 libs and use "-vo x11"?


No. You also need an X server, then run the server, then set properly DISPLAY (and XAUTHORITY; or start X with -ac), wait for X being started. Then you may run mplayer.
xcraft
QUOTE(utx @ Oct 21 2008, 12:36 AM) *
QUOTE(xcraft @ Oct 21 2008, 08:45 AM) *
1- Is there any other way to watch the videos full screen?


-fs. Bus is probably not fast enough to transfer 640x480. For 320x240 it is sufficient, so you have to scale video down and use -vm. It works ony for -vo pxa.

QUOTE(xcraft @ Oct 21 2008, 08:45 AM) *
2- Do i have to change to Angstrom X11?


No, you van use -vo sdl, -vo fbdev or -vo pxa.

QUOTE(xcraft @ Oct 21 2008, 08:45 AM) *
3- Can i just install x11 libs and use "-vo x11"?


No. You also need an X server, then run the server, then set properly DISPLAY (and XAUTHORITY; or start X with -ac), wait for X being started. Then you may run mplayer.



At last i did it thanks to you. "mplayer -vo pxa -vm xyz.avi" worked great but the others did not.

Thanks for your time.
EzerchE
i tried everything but when i enter a command before video link it doesnt open the video, i am trying to rotate the screen video shows vertically and i want to make it horizontally. how can i do that? i tried rotate=1 but when i write it before video link, it doesnt open the video sad.gif
canguy247
QUOTE(EzerchE @ Jan 21 2009, 03:56 PM) *
i tried everything but when i enter a command before video link it doesnt open the video, i am trying to rotate the screen video shows vertically and i want to make it horizontally. how can i do that? i tried rotate=1 but when i write it before video link, it doesnt open the video sad.gif


If you don't have a preceding dash (-) it is taken as a filename.
try:

-vf rotate=1

EzerchE
i tried but it didnt work, it doesnt show video and closes the window immediately. also i tried gmplayer, it show right but too slow for mplayer. is that possible to open gmplayer without visual interface?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.