Help - Search - Members - Calendar
Full Version: Hdh3 Ext3 Conversion Issues
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Sharp ROMs
xamindar
I converted my hdd3 on my c3100 over to ext3 recently to hopefully be gone with the fat32 problems. But now I have a whole new issue and this one seems random. Sometimes after starting up I will be missing some folders entirely and when I do an ls I get this:
CODE
ls: cannot access /media/disk/Documents: Input/output error
ls: cannot access /media/disk/dict1: Input/output error
ls: cannot access /media/disk/debian-kernel: Input/output error
ls: cannot access /media/disk/found.000: Input/output error
ls: cannot access /media/disk/zbedic: Input/output error
ls: cannot access /media/disk/pdaxqtrom-0.8.2: Input/output error
debian-kernel  Documents  lost+found       roadmap     zbedic
dict1          found.000  nand-backup      temp
dict2          kdepim     pdaxqtrom-0.8.2  Zaurus_fix


The ones that are empty re the ones that give that input/output error. I just have to reboot until it works.
Any ideas what causes this? When I plug the zaurus into my linux machine to try to get to the files I get these same error messages. I tried an fsck but it reports no problem. Is there a mount option it needs or something?


EDIT: fsck on zaurus reports fine but fsck on the disk when plugged in as a usb drive gives this:
CODE
Whiterabbit media # fsck.ext3 /dev/sdc
e2fsck 1.41.3 (12-Oct-2008)
The filesystem size (according to the superblock) is 1569960 blocks
The physical size of the device is 521384 blocks
Either the superblock or the partition table is likely to be corrupt!
Abort<y>?


What is causing all this error?
speculatrix
hmm. check your partition table and ensure there's no overlap.

might need to re-do the mkfs. perhaps you changed the end of the partition and didn't remake it?

could there be a script somewhere which is trying to force a file system check for non-ext3?

have a look at "dmesg" output and just verify there's no I/O errors on the drive.
xamindar
You know what? Does anyone know how the usb on-the-go driver works? When I plug it in as a hard drive does it just designate hda3 as the external drive? I am starting to wonder if the driver is hardcoded to a specific size as when I plug it into my linux machine it is reported as a "2.1 GB volume" wheras it is actually around 6 gigs in size. So maybe sense I put a larger internal drive in I just can't use the internal drive as a usb drive any more. Is it possible there is a config file for the pc link or usb connection settings?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.