Help - Search - Members - Calendar
Full Version: Cacko Security Hole
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Sharp ROMs
gazik21
I have my Zaurus running Cacko 1.23 with my Mac Book connected to the same Wi-Fi network.
On my Mac Book in Shared I see Zaurus as a PC Server and I can browse and change the content of the SD card and HDD on it freely without any password.
I knew about this hole before, just didnt know it is so easy to see it on Mac.

Does anybody know how to close this hole?
tux
QUOTE(gazik21 @ Nov 13 2008, 05:39 AM) *
I have my Zaurus running Cacko 1.23 with my Mac Book connected to the same Wi-Fi network.
On my Mac Book in Shared I see Zaurus as a PC Server and I can browse and change the content of the SD card and HDD on it freely without any password.
I knew about this hole before, just didnt know it is so easy to see it on Mac.

Does anybody know how to close this hole?

cool.gif It's all to do with Samba. smile.gif You'll need to study up on the samba documentation. I believe that you can password protect the shares. wink.gif Sorry to be vague but I have never needed to bother. This has appeared in the forums before.If you search the Security and Networking forum you might find some specific suggestions. wink.gif
speculatrix
take a look at /etc/samba/smb.conf and you'll be able to tweak the settings there...

very very briefly: create a username/password in the smbpasswd file for the standard non-privileged user ("smbpasswd -a username"). you can restrict then the shares to that username.
gazik21
fixed it:

- installed smbpasswd - [smbpasswd_0.1-1_arm.ipk] from meanie's feed

- Once you installed smbpasswd, you will need to do the following to get it working:
# su
# ln -s /usr/local/samba/lib/codepages /usr/lib/samba/codepages
# rm /usr/local/samba/lib/smb.conf
# ln -s /usr/local/samba/lib/smb.conf /usr/lib/samba/smb.conf
# ln -s /usr/local/samba/private/smbpasswd /etc/smbpasswd

- then create user zaurus with password of your choice
sudo smbpasswd -a zaurus a

- to connect now: smb://zaurus then user:zaurus and your password

speculatrix
QUOTE(gazik21 @ Nov 20 2008, 11:14 PM) *
fixed it:

- installed smbpasswd - [smbpasswd_0.1-1_arm.ipk] from meanie's feed

- Once you installed smbpasswd, you will need to do the following to get it working:
# su
# ln -s /usr/local/samba/lib/codepages /usr/lib/samba/codepages
# rm /usr/local/samba/lib/smb.conf
# ln -s /usr/local/samba/lib/smb.conf /usr/lib/samba/smb.conf
# ln -s /usr/local/samba/private/smbpasswd /etc/smbpasswd

- then create user zaurus with password of your choice
sudo smbpasswd -a zaurus a

- to connect now: smb://zaurus then user:zaurus and your password



thanks for letting us know.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.