Help - Search - Members - Calendar
Full Version: Angstrom Install - Hard Drive Lost 2.8gb ?
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > C1000/3x00 General discussions
I've been installing Angstrom on my C3100 all day today, and finally got Cacko to dual boot with Angstrom, following these instructions:

The above instructions worked fine, but my problem is with the instructions below, in the part where you repartition the HDD.
When in a console in Cacko, my partitions add up to only 140M, 46M, and 1022M (That's roughly 1.2GB)
I get the same results as above in a console in Angstrom also.
Where did the other 2.8GB go??
As root in a console do the following:

# fdisk /dev/hda

Command (m for help): o (Blow away the partition table)

Command (m for help): n (New partition)
Partition type: p (Primary partition [1-4])
Partition number (1-4): 1 (Root partition)
First cylinder (1-7936, default 1): 1 (Start of disk)
Last cylinder or size: +150M (150 Mbyte, adjust as desired)

Command (m for help): n (New partition)
Partition type: p (Primary partition [1-4])
Partition number (1-4): 2 (Home partition)
First cylinder (293-7936, default 293): [hit enter] (Just after hda1)
Last cylinder or size: +40M (40 Mbyte, adjust as desired)

Command (m for help): n (New partition)
Partition type: p (Primary partition [1-4])
Partition number (1-4): 3 (Root partition)
First cylinder (372-7936, default 372): [hit enter] (Just after hda2)
Last cylinder or size: [hit enter] (Rest of disk)
Command (m for help): w (Write to disk)
I think the directions may have changed. My impression is that / is the first partition, and either /home or swap is the second, with the third being the other one.

You could try doing an "fdisk -l /dev/hda" to see exactly what's going on.
could you have accidentally entered the wrong start for a partition? it would then offset all the others and you'd lose a large chunk of the disk!

1st part would be 1 to +150M, and then after that each partition starts 1 cylinder after the next (fdisk rounds things to the nearest cylinder).

as capn'fish says, what does "fdisk -l" report?
fdisk -l
Disk /dev/hda: 4095 MB, 4095737856 bytes
16 heads, 63 sectors/track, 7936 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1               1         292      147136+  83  Linux
/dev/hda2             293         390       49392   83  Linux
/dev/hda3             391        7936     3803184   83  Linux

df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/hda1               139.1M     64.9M     67.0M  49% /
tmpfs                    40.0k         0     40.0k   0% /mnt/.psplash
/dev/hda1               139.1M     64.9M     67.0M  49% /dev/.static/dev
tmpfs                     2.0M     44.0k      2.0M   2% /dev
/dev/mmcblk0p1          117.4M    529.0k    110.8M   0% /media/card
tmpfs                    30.5M         0     30.5M   0% /media/ram
tmpfs                    30.5M         0     30.5M   0% /dev/shm
/dev/hda2                46.5M      5.3M     38.8M  12% /home
/dev/hda3              1022.0M     64.1M    957.9M   6% /media/hdd
/dev/hdc1               983.1M    492.1M    491.0M  50% /media/cf

Thank you for looking. smile.gif
There must be something going wrong with how this hard drive is being displayed in cacko and angstrom.
I connected my zaurus to a box with Puppy linux. I did this in cacko because USB is not working in angstrom.
The display in Mut shows that my hda3 (vFat partition) is 3803.2Mb

using df -h in both cacko and angstrom, shows it as 1022.0M

I took a screenshot of Mut running in Puppy
That is odd! I really don't know what to say.

If there's nothing on hda3, you could try recreating the partition/reformatting it.
I did try fsk.vfat -F 32 /dev/hda3

again and did the

fsck.vfat -a -f -t -v -V

It remained the same. I would like to make a swap drive sometime in the future, but was waiting until I can get this sorted out

I'm scared if I try fdisk, i'll blow away my other 2 partitions with angstrom installed to it.
OK, next I booted back to cacko and connected in storage mode to my windows box.
It shows .99 GB
This is about the same as in df -h shown in my earlier posts. smile.gif

I'm at a loss, I really don't want to start all over, reflashing/re-installing.
I tried running e2sfck on /dev/hda1 in emergency console and I always got superblock errors;
The superblock could not be read or does not describe a correct ext2 filesystem.  If the device is valid and it really contains an ext 2 filesystem (and not swap or ufs or something else) then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck - 8193 <device>
I tried this several times, then decided to try it in a console while in Cacko, (thinking there would be a later version of e2fsck)

I got the same results in Cacko.
Then I tried googling.
Now I tried substituting the number for the superblock location with several numbers that I found in articles about this problem.
Still no luck. Angstrom seems to run fine on this partition.
Is my drive hosed?? Is this repairable?
Below is the output of fdisk -l (for /dev/hda1)
Notice the first line that says: Disk /dev/hda1: 1031 MB, 1031127552 bytes (I actually partitioned this as 150M)
fdisk -l /dev/hda1

Disk /dev/hda1: 1031 MB, 1031127552 bytes
32 heads, 63 sectors/track, 998 cylinders
Units = cylinders of 2016 * 512 = 1032192 bytes

Device Boot         Start       End      Blocks      Id  System
/dev/hda1p1   ?      952357     1222415   272218546+  20  Unknown
Partition 1 has different physical/logical beginnings (non-Linux?):
     phys=(356, 97, 46) logical=(952356, 20, 3)
Partition 1 has different physical/logical endings:
     phys=(357, 116, 40) logical=(1222414, 22, 41)
Partition 1 does not end on cylinder boundary.
/dev/hda1p2   ?      659814      927163   269488144   6b  Unknown
Partition 2 has different physical/logical beginnings (non-Linux?):
     phys=(288, 110, 57) logical=(659813, 18, 61)
Partition 2 has different physical/logical endings:
     phys=(269, 101, 57) logical=(927162, 30, 8)
Partition 2 does not end on cylinder boundary.
/dev/hda1p3   ?      267356      960989   699181456   53  OnTrack DM6 Aux3
Partition 3 has different physical/logical beginnings (non-Linux?):
     phys=(345, 32, 19) logical=(267355, 27, 11)
Partition 3 has different physical/logical endings:
     phys=(324, 77, 19) logical=(960988, 7, 54)
Partition 3 does not end on cylinder boundary.
/dev/hda1p4   *      691780      691791       10668+  49  Unknown
Partition 4 has different physical/logical beginnings (non-Linux?):
     phys=(87, 1, 0) logical=(691779, 19, 3)
Partition 4 has different physical/logical endings:
     phys=(335, 78, 2) logical=(691790, 5, 45)
Partition 4 does not end on cylinder boundary.

Partition table entries are not in disk order
it does look quite screwy but not necessarily disastrous.

it's normal to create partitions on cylinder/track boundaries, although these days with drives being zoned there number of sectors per track varies across the disk so it doesn't really matter.

the drive being reported as the wrong size *might* be down to the fact it's more than 2GB and the linux tools are out of date somehow?
I repartitioned it inside of cacko's terminal.
After many hours of reading documentation, I realized I needed to unmount all the partitions first. I never did that in windows, I use PQ magic.
In cacko, I just deleted all partitions, then created new ones. This fixed my "size" problem. I now have 4095 MB
Then I needed to reflash Angstrom.
Then I needed to place the contents of hddsys files from Sharp, into the proper directories to enable cacko to dual boot with lexec.

I have just finished it today.
smile.gif smile.gif

Ah, I have had interesting problems with PQ Magic; I've avoided using it of late. Now that cheap external hard drives are so cheap, it's easier to take a snapshot and recover from backup.

When I've wanted to fix windows up, I've found Acronis to be excellent.

Well done for persisting. If it had worked perfectly, you'd not have learned anything, would you cool.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.