Help - Search - Members - Calendar
Full Version: 2 Gb Sandisk Ultra2 Sd Card Problems [fixed]
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
Jon_J
*** Edit: Fixed by formatting in digital camera. - see post #2***
I have a 2 GB Sandisk Ultra2 SD card that's pretty new and has only been used for storing files.
It's never had a swapfile on it, or ran apps or operating systems on it.
It works fine in Cacko, pdaxii13, my camera, and both of my desktop PCs
Below is output of "dmesg" and "ls -l" on Angstrom and pdaxii13:
(a pic of gpe-filemenager in Angstrom and Rox filer in pdaxii13 are attached)
CODE
Angstrom:

dmesg
<6>mmc0: new SD card at address 8000
<6>mmcblk0: mmc0:8000 SD02G 1985024KiB
<6> mmcblk0: p1

cd /media/mmcblk0
ls -l
-rwxr-xr-x  1 root  root  0 Jan 1 1980 1?
-rwxr-xr-x  1 root  root  0 Jan 1 1980 9?
-rwxr-xr-x  1 root  root  0 Jan 1 1980 a?
-rwxr-xr-x  1 root  root  0 Jan 1 1980 i?

----------------------------------------------------------------
pdaxii13:

dmesg
pxa_sd_wait_response: response time out (cmd=52 MMC_STAT=0x2142)
pxa_sd_wait_response: response time out (cmd=05 MMC_STAT=0x2142)
[SD]-clustersize = 10000
mmcda: mmcda1
mmcda: mmcda1
mmcda: mmcda1
MSDOS FS: IO charset utf8

cd /mnt/sd
ls -l
drwxrwxrwx  2 root  root      4096 2007-02-03 18:37  Backup_Files
drwxrwxrwx  4 root  root      4096 2007-02-03 22:30  Documents
-rwxrwxrwx  1 root  root    122611 2007-10-16 03:37  icecc_2.9_armv5tel.ipk
drwxrwxrwx  3 root  root     12288 2008-02-06 16:30  lofiversion
drwxrwxrwx  2 root  root      4096 2008-11-13 12:15  NIKON
drwxrwxrwx  2 root  root      4096 2007-09-25 13:55  QtPalmtop
-rwxrwxrwx  1 root  root    214726 2007-10-14 13:00  rox-desktop.png
-rwxrwxrwx  1 root  root    221177 2007-10-16 12:36  rox-icewm.png
-rwxrwxrwx  1 root  root     80929 2008-04-11 16:14  screencap1.png
-rwxrwxrwx  1 root  root     74632 2008-11-16 15:47  screencap2.png
-rwxrwxrwx  1 root  root        40 2007-01-29 10:25  sd-card-directory.txt
drwxrwxrwx  6 root  root      4096 2007-02-03 18:38  web
-rwxrwxrwx  1 root  root       421 2007-02-20 02:35  wifi-radar.conf
-rwxrwxrwx  1 root  root     19101 2007-02-19 21:04  wpa_supplicant.conf
-rwxrwxrwx  1 root  root  17292955 2008-04-28 12:41  youtube_coat_hanger_antenna.flv
Jon_J
After much fsck.vfat and checking partition table with "fdisk -l", it still didn't work in Angstrom.
The first time I used fsck.vfat, it found some broken chains from an offline file copy of this forum.
This had thousands of tiny files in it. I deleted that and any other files I didn't need anymore.
Then I moved the rest of the files off it in windows.
Then back in angstrom, I tried mkfs.vfat -F 32
That didn't help much, I kept getting partition table errors under fdisk -l
I didn't want to partition it, since I want to just want to use the full 2GB of it as it shipped.
So next I formatted it in windows as FAT 32
It still didn't want to work in Angstrom, although the used space had changed under df -h
Finally, I decided to format it in my digital Nikon camera.
I read about formatting cards in a camera on this forum and other PDA forums to "fix" a troublesome card.

Well, that did the trick, it worked! smile.gif
Now it appears in /media/card instead of /media/mmcblk0
I moved my files back to it and they are now available in Angstrom
utx
QUOTE(Jon_J @ Dec 12 2008, 10:12 AM) *
I read about formatting cards in a camera on this forum and other PDA forums to "fix" a troublesome card.


Some flash manufacturers use strange formatting tools creating an incorrect VFAT. There was a kernel bug: such media were mounted, but incorrectly handled.

It may be the very same problem as this one: https://bugzilla.novell.com/show_bug.cgi?id=91189#c37 (only comments 37-40, the rest was identified as different problems). The bug seems to be away in latest kernels, so Angstrom 2008.1 should have this fixed.
craigtyson
I've had similar issues with SD cards. It seems that the only solution is to blow everything away using a camera. A windows and Ubuntu PC wern't much use.

C
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.