I have previously been unable to get USB/IP syncing to work. I settled on USB I/O, but it stopped working today. I have noticed others with IP sync issues.

There are 2 files of interest that get created/updated automatically after switching to USB IP in the PC Link application:

/etc/hotplug/usbnet.conf:

This is the local USB IP address that will be assigned per the PC Link application, the default is:

IP=192.168.129.201
NETMASK=255.255.255.0
DHCPS=yes
DHCPC=no

/etc/hotplug/dhcpcd.conf:

This is the dhcp server information passed to your PC, the default is:

subnet 192.168.129.0 netmask 255.255.255.0 {
range 192.168.129.1 192.168.129.1;
option netbios-name-servers 192.168.129.201;
option netbios-node-type 8;
default-lease-time 600;
max-lease-time 7200;
}

My IP problems started when XP did not get 192.168.129.1 as its IP address on the USB/IP interface. I have VMware installed and it's default IP for NAT is 192.168.129.1 preventing its use on another interface.

Changing both the Zaurus Manager and the PC Link settings to 192.168.130.201 updated the above files and handed Windows a 130.1 address and IP syncing now works.

Hopefully the above info will help others troubleshoot IP sync issues.

Non-USB IP sync.

I have been successful using BT to IP sync.

1. Disconnect USB cable.
2. Turn off/on Z to get rid of usb0 interface (ifconfig usb0 down should also work)
3. I setup BT PAN with XP, XP has 192.168.131.1 address and Z has 192.168.131.201 address.
4. Change both PC Link and Zaurus Manager to have 192.168.131.201 address.
5. Select sync from XP, the sync button on the Z did not work, it reported a comm error.

I see to reason why WiFi or any other method would not work.

I would like to get the sync button on the Z to work, any ideas?