Help - Search - Members - Calendar
Full Version: Ubuntu On Sl-c760 "husky"
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Ubuntu
Wood
Just started zUbuntu on SL-C760. Some error messages are shown when booting:

/usr/sbin/alsactl: load_state:1313: Cannot open /var/lib/alsa/asound.state for reading: No such file or directory
/usr/sbin/alsactl1: save_state:1251: No soundcards found...
Can't open display: 0

Logging in as root is possible. Starting Xserver with startx works, but the screen is rotated (portrait) and the stylus has got problems.
Mouse arrow and stylus are not in sync, and clicking is not possible. The Xserver shows the following messages:

Extended Input Devices not yet supported. Implement it at line 637 in kinput.c
Audit; Thu Jan 1 00:17:21 1970: 1393 X: client 4 rejected from local host (uid:65534)
selected device is not a touchscreen I understand

Any idea how to fix these issues?

Richard
cortez
Check out the comments on my blog for some solutions. Regarding the problems you mention:
QUOTE
Run "nano ~/.xinitrc" and remove the "xrandr -o right" command. I didn't realize this isn't needed for c7x0.
Run "nano ~/.profile" and change the TSLIB_TSDEVICE line in there. I think that event2 should be replaced by event1 for c7x0.
Use ts_calibrate to re-calibrate the screen
Add the following entries to /etc/modules for working sound and CF slot (c7x0 only!)
snd-soc-corgi
pxa2xx_cs


Cheers,
cortez
Wood
Issues are fixed! Thanks!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.