Help - Search - Members - Calendar
Full Version: Zubuntu Rotation - Doesn't On Sl-c860
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Ubuntu
zmike
Regarding rotation, I saw some references to x11-xserver-utils and xrandr to get rotation working.
I have both but changing the orientation of my SL-C860 doesn't do anything.

Is there something I'm missing?

Thanks!
Mike
Capn_Fish
I suspect the /etc/zaurusd/... scripts aren't correct for the SL-Cxx0 models, and I don't know how to fix them (you could try taking them from Angstrom, I believe they work there).

Have you tried manually doing the rotation, eg:

CODE
xrander -o n


where 0 <= n <= 3?
zmike
Thanks for the reply!
doing a manual rotate works but swinging the screen does nothing.
1 - portrait
0 - landscape

The events don't seem to trigger.

- Mike
cortez
You're right, the hinge detection is b0rked somehow. I will have a look to find out if this can easily be fixed.
The same applies by the way to the Spitz and Akita models, auto-rotation doesn't work on these either.
brontoZaurus
something about landscape mode in console-only mode, it boots in portrait mode and this trick is only for X i think
YoG
QUOTE(Capn_Fish @ Jan 15 2009, 06:31 AM) *
I suspect the /etc/zaurusd/... scripts aren't correct for the SL-Cxx0 models, and I don't know how to fix them (you could try taking them from Angstrom, I believe they work there).

Have you tried manually doing the rotation, eg:

CODE
xrander -o n


where 0 <= n <= 3?


I think the problem is with the X authorization. Run:

CODE
xhost +


this will enable free access to the X server.
Also, I don't remember, but I think the states were switched in /etc/zaurusd/scripts/zaurus-hinge.conf in my case state 0 is landscape and state 2 is portrait.

update:
After rebooting there was no problem with the authorization.

YoG.
brontoZaurus
Ok, thanks man, i´ll give a try and post feedback!

Edited:

the main problem was that when is booting, THAT shell, boots in portrait mode, i have used only the RC1 filesystem and 2.6.31 rc3 Kernel and modules from cortez´s blog.
i need to use some patches or soż?
today i have 8.04 running from microdrive working flawesly but i would like to upgrade. ext4 support, performance...
YoG
QUOTE(brontoZaurus @ Jul 24 2009, 10:25 AM) *
...boots in portrait mode...


Well, to solve this all I had to do was to remove
CODE
xrandr -o right

form ~/.xinitrc

YoG
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.