Help - Search - Members - Calendar
Full Version: Upgrading To Angstrom
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
Storm
Hey all,

Been a long time. I am [still] running Hentges OZ 3.5.4.1 on my Collie, which is obviously really, really long in the tooth. I was thinking about getting a Nokia N810, but took a look at Angstrom, which is now supported on the Collie. (Unlike the last time I checked.)

So I have gone out and bought a shiny new 2GB SanDisk SD card, and have the 2007.12-r19 installkits downloaded to my laptop.

My question is what gotchas or problems should I expect? I see several issues on the two install pages I found, but the information seems a bit dated...so I thought I would ask here for a canonical list of what does/does not work, which installkit I should use (r19 seems to be all that is in unstable).

What is the best install method to use? Should I do the untar on CF card and C-D-Reset or "transform a small generated rootfs.tar.gz into a big-rootfs.bin for altboot to boot on it"?

Are the 2007 repos up to date?

Is there anything else that you can tell me before I blow OZ away and step into a new world?

Thanks,
--Storm
Capn_Fish
I really don't know about install methods, but Kexec is a good way to go, IMO, though I don't know if Collie is supported.

The Angstrom stable branch (2007.12) is fully functional AFAICT. I don't remember having any issues with it.

The downside is that some/many packages aren't available for 2007.12, or they're older versions than those in the unstable branch.

Also remember that I don't have a Collie and that this is from an SL-C3100 perspective.
Storm
QUOTE(Capn_Fish @ Jan 18 2009, 03:29 PM) *
I really don't know about install methods, but Kexec is a good way to go, IMO, though I don't know if Collie is supported.

The Angstrom stable branch (2007.12) is fully functional AFAICT. I don't remember having any issues with it.

The downside is that some/many packages aren't available for 2007.12, or they're older versions than those in the unstable branch.

Also remember that I don't have a Collie and that this is from an SL-C3100 perspective.


Well, I can comfort myself in knowing that it is more up-to-date than OZ 3.5.4.1. smile.gif

I tried the upgrade, using the traditional write-to-CF, C-D-Reset dance, but when I do, the lights only stay lit for a few seconds. I did insure that zImage.bin was named zImage, but alas, no joy.

Ideas?
--Storm
Capn_Fish
I'm not familiar at all with the 5x00s, so you'll have to ask somebody who is. Sorry.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.