Help - Search - Members - Calendar
Full Version: Angstrom 2008.1 On Sl-c760 Is Dead After 30 Seconds
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
BerndS
Hi,

did anybody manage to get the Angstrom 2008.1 image running on a SL-C760?

I tried mostly all 2008.1 images from this page:

http://www.angstrom-distribution.org/unsta...autobuild/c7x0/

and no one worked. The problem is always:

The SL-C760 boots the new image and is usable for about 15 to 30 seconds (e.g. I can connect via IP and open applications on the Zaurus) . Then the Zaurus hangs - it ignores all keys and the stylus and does not answer to IP connections anymore.

I get this behaviour for all images (console/gpe/opie).

I also created a new image from the repository using bitbake. This image also hangs.

The 2007.12-r19 image of Angstrom works fine on the SL-C760.

Any hints where to look for the error?

regards

Bernd
utx
QUOTE(BerndS @ Jan 27 2009, 09:58 AM) *
The SL-C760 boots the new image and is usable for about 15 to 30 seconds


Try to kill ipaq-sleep. Maybe you will nedd to kill tskeys as well.
BerndS
QUOTE(utx @ Jan 27 2009, 12:54 PM) *
QUOTE(BerndS @ Jan 27 2009, 09:58 AM) *
The SL-C760 boots the new image and is usable for about 15 to 30 seconds


Try to kill ipaq-sleep. Maybe you will nedd to kill tskeys as well.


That would be difficult in the short time the Zaurus is usable ..

Can I build an image without these packages?

regards

Bernd
utx
QUOTE(BerndS @ Jan 27 2009, 02:01 PM) *
QUOTE(utx @ Jan 27 2009, 12:54 PM) *
QUOTE(BerndS @ Jan 27 2009, 09:58 AM) *
The SL-C760 boots the new image and is usable for about 15 to 30 seconds


Try to kill ipaq-sleep. Maybe you will nedd to kill tskeys as well.
That would be difficult in the short time the Zaurus is usable ..

Can I build an image without these packages?


I guess that yes, but I never tried it. ipaq-sleep work incorrectly in console and suspends Zaurus even if you are working on it. If your problems are caused by ipaq-sleep, your machine goes to sleep (and it may fail). On my machine (SL-C3200) the period is sufficient to login in console and kill it. tskeys "only" eats CPU time.

You can also start emergency system and delete them.
BerndS
QUOTE(utx @ Jan 27 2009, 01:36 PM) *
I guess that yes, but I never tried it. ipaq-sleep work incorrectly in console and suspends Zaurus even if you are working on it.


So this is a known problem and will be solved in the future? If yes, I stay with Angstrom 2007.12 and wait until the error is fixed (if I only get bitbake working for 2007.12 ...).


QUOTE
You can also start emergency system and delete them.


I'll try that

BTW: What are the side-effects of disabling ipaq-sleep? Only automatic suspend won't work (but manual suspend still works)?


regards

Bernd
utx
QUOTE(BerndS @ Jan 27 2009, 02:55 PM) *
BTW: What are the side-effects of disabling ipaq-sleep? Only automatic suspend won't work (but manual suspend still works)?


Automatic suspend will not work. (ipaq-sleep bases it on X activity, if you are working in console, it goes to sleep during work)
BerndS
QUOTE(utx @ Jan 27 2009, 03:26 PM) *
QUOTE(BerndS @ Jan 27 2009, 02:55 PM) *
BTW: What are the side-effects of disabling ipaq-sleep? Only automatic suspend won't work (but manual suspend still works)?


Automatic suspend will not work. (ipaq-sleep bases it on X activity, if you are working in console, it goes to sleep during work)


Just checked my self-created image .. there is no ipaq-sleep in the image
(this is Angstrom with OPIE)

regards

Bernd
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.