Help - Search - Members - Calendar
Full Version: Evdo Usb 727 With C3100 ?
OESF Forums > General Forums > General Support and Discussion > Accessories
c3100
I see various postings on tethering through bluetooth to phones for some of the zaurus devices (but I thought BT through SD wasn't supported on the 3100?).
Anyhow, I was wondering if anyone had any information on trying to make a USB727 evdo work with Zaurus?
I have this dongle working on my linux laptops through ppp no problem, but I notice when I plug in (using adapters) to my Zaurus, the 727 doesn't even light up at all (the way it does when plugged into the laptop USB). Is this a lacking power issue (no messages in dmesg either).
Is this only possible with an external powered USB hub? Anyone even tried?
Thanks!
utx
QUOTE(c3100 @ Feb 14 2009, 10:15 PM) *
Anyone even tried?


I am using a different dongle, but 99% of USB BT dongles are standard and compatible.

Possible problems:

- You didn't switch to host mode (the default is client mode, however some kernels incorrectly send power even in client mode). See lsusb, you should see at least USB host device.
- Dongle manufacturer incorrectly claim power requirement. Typical dongle needs 60mA, Z supports 150mA. If the device claims more, it is rejected. See lsusb -v for claimed power. There is several way to work-around: powered hub, sysfs quirk (can be found somewhere on OESF), patched kernel
- BT daemons are not running. Dongle works, but no services. Depending on the dongle, light may be down. Run /etc/init.d/bluetooth start (may depend on distro)
- Dongle in HID mode by default. Running hid2hci may help to switch to HCI (BT "host").
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.