Help - Search - Members - Calendar
Full Version: How Do You Input Function Keys?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Ubuntu
dproldan
I need to press F10 for entering a program option (openMSX), but I'm lost. I've tried modifying keymaps and modmaps with no luck

I haven't found the way either witht the zaurus keyboard or an external USB keyboard.

Any clue?
Capn_Fish
You should be able to do it in your Xmodmap (assuming it's being loaded). Does changing other keys work?
dproldan
Yes, changing standard letters work perfectly.

I supposed that pressing "Fn" + 1-0 would send F1-F10, but it doesn't. Is that the correct key combination?

Thanks
Capn_Fish
In your Xmodmap, you should have lines something like these (keycodes are random and almost certainly not correct):

CODE
keycode 63 zero exclam F10 F10


The point being that the columns go normal press, shift press, Fn press, Fn + Shift press.

Does that help?
dproldan
Yes, I have those lines in xmodmap. I'm using that Jaunty zubuntu install.

I've even tried to put "F10" at those positions on all the number keys, unsuccessfully.

Finally. I had to map it to the right shift key. But of course I can only access F10. Unfortunately, openMSX on the zaurus is too slow to be usable at the moment.

I guess Xbindkeys has something to do with this problem. But even if I kill it, function keys still don't work.

Capn_Fish
And all the other Fn key-combos work fine? I'm out of ideas then. sad.gif
dproldan
nope, no funtion key work at all. Do they work for you?

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.