Help - Search - Members - Calendar
Full Version: How To Extract Filesystem
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus Distro Support and Discussion > Ubuntu
I'm having a great time with zubuntu (thanks to Cortez, I'll be making a donation soon! dry.gif )

Now that I have Zubuntu working in my SL-C1000, I'd like to install and run Cacko from the same SD as well. Since I was planning on multibooting Cacko and pdaXrom in the future, I basically exactly duplicated the partition layout which Cortez shows in his Omegamoon instructions. The first step is to get Cacko working and booting off the SD...

I think I can figure out how to get a kernel-cmdline working based off the /proc/cmdline data in Cacko. My main problem is: How do I get a copy of the Cacko filesystem?

I can install Cacko in my other SL-C1000, and I suppose then copying everything from there would be feasible. On the other hand, is there any way to get the whole filesystem image from my laptop using either the Cacko 1.23 install files, or a NAND backup from a SL-C1000 with Cacko installed on it?

I'm just wondering how you guys did it (including Cortez, which seems to have this working judging by his SD card partition setup.) I really want to run Cacko off the SD and not the NAND.

Thank you in advance, and congratulations for the hard work put in this great distro!

An update: I found out how to extract a NAND backup, so I extracted the root partition from my Cacko 1.23 NAND backup which is an initial setup without modifications.

Then I used the killJazz kernel for Akita as the zImage in the /boot directory, and created a kernel-cmdline by copying the output of /proc/cmdline (but replacing /dev/mtdblock2 with /dev/mmcblk0p3, which is the partition where the cacko root filesystem is in my installation.) I also created the nfo file.

I booted up, and kexecboot picked up cacko and showed it as an option. I selected it, and then the cacko kernel started to boot. Things looked OK, but in the end I got a kernel panic (init not found.)

I tried different kernel-cmdline combinations, but none of the ones I have tried have made things any different, and I'm out of ideas.

I don't know how the kernel looks for initd. If its location is hardcoded in the kernel, then I suppose we are out of luck with this approach, since copying the root filesystem to the new partition must have necessarily changed the memory layout. (Side note: I was investigating also about using dd to make an exact duplicate of the /dev/mtdblock2 partition in my cacko installation as well, but I don't know how to (first of all) create an empty partition which is an exact duplicate as far as block size and so forth.) I have the feeling my newbie status with this stuff is probably not helping me. rolleyes.gif

If anybody has any ideas it would be great. I might start a new thread sometime soon with a report of my progress, and maybe someone more experienced can give this the last touches to get it completely working.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.