Help - Search - Members - Calendar
Full Version: Unresolved Inheritance Operation
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Ubuntu
I am currently polishing zubuntu installation on c1000.

xpaint, xpat2, xfig gives me unresolved inheritance operation error.

I have libxt6 1:1.0.5-3 on my Z and according to this it should be fixed in this version.
Or maybe in this version in jaunty?

Any way, how to fix this?
Where do I find that library fixed?
I have the same problem with xpdf. I haven't investigated much about this though, because I'm trying to get Cacko and pdaXii13 into full SD installations in a kexec setup. But I would be interested to know the solution to this. I didn't upgrade to Jaunty, by the way. Did everybody else do that?
OK. As usual i have found solution smile.gif

just fetch
unpack libXt6 from there to /usr/lib (remove old one to safe place, just in case something goes wrong) do a ldconfig "i gotowe" smile.gif
xfig, xpat2 xmpuzzles are working fine.
Thank you for checking into this. I'll give this solution a try when I flash Zubuntu again (messing with pdaXii13 at the moment.)
Well done! smile.gif

BTW, I just posted in the pdaXrom forum, and unfortunately it was the first post in almost 1 month. The Zubuntu forum is not much livelier, and I assume this is a function of the Zaurus being discontinued and people moving to other platforms (maybe netbooks?) Too bad really, as these are awesome machines, infinitely configurable.
this solution works also for xpdf. It segfaults on old version of this library but now it works fine on my Z.
QUOTE(ptoki @ Jul 10 2009, 12:37 PM) *
this solution works also for xpdf. It segfaults on old version of this library but now it works fine on my Z.

Awesome, thanks again! laugh.gif
this worked, but now apt keeps complaining that i have broken packages doing this. How do i get apt to accept the armel lib?
I guess this is not a must anymore, as the libxt6 has been updated.
I installed Zubuntu 1 a couple of days ago. and had tha same problem. I just did the apt-get update and then reinstalled libxt6, and that fixed the problem.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2016 Invision Power Services, Inc.