Hello,

after changing my Netwalker's locale setting to German I noticed the keyboard layout was changed accordingly as well - this didn't affect Gnome for some reason, but the console and every other DE/WM (I tried Openbox/LXDE and Xfce4).

Fairly easy to fix:

CODE
sudo dpkg-reconfigure console-setup


When asked for keyboard origin/layout, select Japan. Everything else can be left at default settings.

HTH! smile.gif