Help - Search - Members - Calendar
Full Version: Akita Multiboot "how To" Help
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus Distro Support and Discussion > Ubuntu
I have tried most "how to" in this forum and elsewhere and none have worked for me. I am not a developer but a user of the Zaurus. So when an "how to" assumes it is clear to everybody without actually including all the detailed steps, it does not always work for everybody, as shown in many of the posts in this forum. I have tried almost all distros by flashing them on my Akita and they all worked fine. But now the emphasis is more and more on kexecboot or multiboot methods. So I would like to write a complete multiboot "how to" for users (not developers) for the Akita hopefully with all your help.

Here is what I want to do:

1- Have multiple OS for my SL-C1000 on a SD card
- Zubuntu 2.0
- Cacko 1.23
- Angstrom
- Poky
- Igelle (
2- Use the kexecboot or Omegamoon version

I have been using mainly Cacko but I now need to have a more mini computer (with Perl, Pyton, PHP and Apache) for when I am on a train or plane. I also mainly travel by bike and carrying a laptop is not an option for me, I need to travel as light as possible hence the Zaurus is perfect for that.

Here is what I tried so far:

1- I have configured a 2GB SD card with ext3 using fdisk and mkfs the same way as on Omegamoon:
2- I already had Cacko running on my Akita (capable of reading SD cards higher than 1GB)
3- I obtain the Katastrophos rootfs files and modules from this post:
4- Put the them on one of the partition of the SD card
5- Obtain the Sptiz Zubuntu 2.0 rootfs and addition files from this page:
(That actually did not work, when I tried to gunzip and tar -xvf the content on my Linux box, I got a few mknode permission denied).
6- Put them on a 1GB partition on the SD card
7- Obtain the kexecboot kernel and update file from Omegamoon:
8- Put them on a CF VFAT card (my SD card formatted as VFAT did not get recognized by my Akita)
9- Flashed update them on the Zaurus and rebooted as per the instruction on Omagamoon:
10- After rebooting my Akita, I obtain the Omagemoon kexecboot menu with 2 items in the list, one for Cacko and one for Zubuntu.
11- Selecting the Cacko did not work, got a kernel panic (init not found)
12- Selecting the Zubuntu did not work just stopped in the console and never booted the actual desktop.

I read all the posts in this forum related to this topic and there are many incomplete solutions but none of them seem to work for me.

So I want to start from the absolute beginning and want to write down every single steps that need to be taken for using kexecboot on Akita. Remember this is for the users not the developers.

Step 1: Format a SD card

- Partition and make an ext3 filesystem on a 2GB SD card with some swap space
(enter the exact and complete steps here)

Step 2: Prepare your Zaurus

- ...

Step 3: Obtain rootfs files, kernel-cmdline, kernel images for each OS

etc. ...

Shall we start?

Thank you for your help.
For Prepping your Akita, do a trisoft nand restore. this will get your partition tables correct and proper.

flash cacko per the cacko instructions, BUT make sure that the root partition is 53MB no more, no less.

once this is done, boot into cacko to verify that it flashed correctly.

on your sd card, for the cacko that is now in nand, you only need the /boot folder.
sd /boot should have 3 files in it:
the cacko kernel that you want to use.
Kernel command line: console=ttyS0 root=/dev/mtdblock2 mtdparts=sharpsl-nand:7168k@0k(smf),59392k@7168k(root),-(home) jffs2_orphaned_inodes=delete EQUIPMENT=0 LOGOLANG=1 DEFYEAR=2006 LOGO=1 LAUNCH=q

Image.nfo file that is plain text that identifies this kernel/ distro


flash the multiboot kernel from omegamoon (it is modified to read the .nfo otherwise it is the same as angstrom)

reboot and insert your special sd card.

you should see cacko with a sd icon, select it and cacko should load now.

I have not gotten the extracted rootfs from cacko to work when it is on a sd card. I think that there are too many pointers to the nand and there is some weird jffs2 linking to cramfs, for me to untangle it. flash cacko to nand and be happy.

multibooting does weird things to cacko, you can't dl too many packages at once, cacko gets confused and becomes unstable. Install a couple of packages at a time, then reboot. this is stupid, but it works and i think it has something to do with the fs switching compression algorithms or something.

if cacko is working for you with the multiboot kernel on nand, then in your zubuntu sd partition, extract the rootfs of your choice from omegamoon, and try booting from it. personally i prefer the hardy/8.04 version zubuntu rootfs. (quick and lightweight)

more to follow....need sleep.
I confirm what duo describes. I did my c1000 according to this recipe and got dual boot cacko+zubuntu.
Actually i have spare 1 gig sd so i can try another distro. But not now, too much work.
Additionally I made two partitions on sd card to have cacko and zubuntu on one card.
And about instaling under cacko.
I have quite polished installation with loads of goodies and did backup (the one from settings tab).
After multibooting I did restore and all works fine (not tested all but have no problems so far).
I managed to have Cacko running from NAND on my Akita as per the instruction with the kernel image in the boot directory of a SD card (ext2). Once it has booted in Cacko, can I remove the SD card? I will also try putting the kernel image and kernel-commandline file in the /boot directory of the NAND and see if I can boot without the SD card as done in another duo post.

I have a lot of problems with my SD cards trying to make them work with the Zaurus. Seems like GParted actually corrupts the SD cards on Ubuntu 9.04. The card I am using does get mounted in my Zaurus (2.0GB SD, and yes I have the Testsu Kernel) but it does seem to show the correct partition and does work at booting Cacko:


$ sudo fdisk -l

Disk /dev/mmcda: 2032 MB, 2032664576 bytes
255 heads, 63 sectors/track, 247 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/mmcda1 1 123 987966 83 Linux

The next step did not work for me. I downloaded the Zubuntu 2.0 from Omegamoon, extracted the rootfs and addition files to a ext2 1.0GB SD card (this one actually gets mounted when put in my Zaurus). Put it in my Zaurus and rebooted. Zubuntu does show in the list in the Omegamoon boot menu, but after I select it, I get a Kernel Panic message after several fast moving error messages. Any idea why it would do that? I did not change anything from the downloaded files, only extracted them on the SD card as is.

Also each time I try to extract Zubuntu 2.0 or RC1 I always get mknod errors (permission denied, I guess trying to create the device block). Should I extract as root or using sudo?

Once I have Zubuntu working from a SD card I want to get Angstrom running and perhaps Poky also from the SD card. After I have everything running I will put all the detailed steps including all the commands needed.
I now have Cacko running on NAND via booting with the Angstrom kexecboot kernel. I just copied the content of the /boot I had on my SD card for the Katastrophos kernel and it worked without the SD. I then tried the Zubuntu 2.0 and the Angstrom build from the online builder on a 1GB SD card (ext2) but none want to boot. They appear in the kexecboot menu, but once selected, I only get the following message at the end:


Warning: unable to open an initial console.

I did not change anything from the downloaded rootfs files and just extracted them to the SD card.

Cacko 1.23 is on the Akita NAND with a 53MB partition.

I am missing anything? Why it does not want to boot?
try using ext3. i have a sd card with a partition for zUbuntu Jaunty and zUbuntu Karmic and they are ext3.
Actually, I think the problem is when I untar the rootfs file from the online builder on the SD card, it creates all the directory structures, but does not automatically do the mknod devices. So looking at the /dev directory, they are just like normal file (no blocks or character special files). I never seen documented that when you want to use Angstrom, you need to do all the mknod yourself. I did that (for console, full, null, etc.), it did start to boot, but now it says that a lot of files are missing in /proc. Any ideas anyone?
is the dev directory look normal under mc?
I think tar has some special option to treat dev files differently.
I dont remember how I did it but I almost always use mc to deal with archives so try to look at tar archive with mc and confirm that dev files are extracted as normal files.
I wish there was some clear documentation! I just want to be a user of Angstrom!

mc does not show the file different from doing ls -al. None of the file in /dev have been mknod.

Since none of the mknod were created after untaring the archive, I attempted to create them manually based on the info on this link:


mknod -m 660 /mnt/card/dev/console c 5 1
mknod -m 660 /mnt/card/dev/null c 1 3
mknod -m 660 /mnt/card/dev/tty1 c 4 1

I then did this:


mount -t proc none /mnt/card/proc
mount -o bind /dev /mnt/card/dev

I then rebooted, selected Angstrom and it got me one step further, I got an Angstrom login in the console (the build I am trying is xfce). It asks me for a login, what do I type? I was expecting it to show me the xfce desktop, but no just the console. Since I can not login, I am stuck again.

Any clear instruction anywhere?
I tried login as root and got the following error


/bin/login: error while loading shared libraries: cannot open shared object file: No such file or directory
Finally got Zubuntu 2.0 working. It was probably th SD card and/or the way I untar the file system.

After making the SD ext2, I untar using this command from a Ubuntu laptop:


cd /media/disk
sudo tar -xvpf /home/mivilleb/Documents/Zaurus/Angstrom/zubuntu-desktop-v2.0.tar.gz
sudo tar -xvpf /home/mivilleb/Documents/Zaurus/Angstrom/spitz-root-addition-v2.0.tar

This time all the /dev files where properly mknod.

Put the SD card in my Akita, booted and selected the Zubuntu choice from the boot menu

Got the login, type root and enter, got the prompt and type startx. That worked and I got into Zubuntu desktop! Can not use the turn off button. Very slow for most application, but it works, can't seem to make my Planex WiFi card to work, so not sure how I will get any other package installed.

Also tried again Angstrom using the same tar command and it created the proper /dev files this time (-xvfjp instead because it is a bz2 file), but when I tried to boot, it get stuck at this message:

pxa2xx-udc pxa2xx-udc: UDC connecting

Any idea?
do you have your cf wifi card inserted when you boot angstrom? If I recall correctly pxa2xx is the cf driver.
modprobe pxa2xx_cs in zubuntu to get the cf slot working.
With the Planex card in before booting, Angstrom still stay at the "pxa2xx-udc pxa2xx-udc: UDC connecting" line, while the Zubuntu does not recognised it.
Well, Angstrom just does not boot properly. The rootfs and image are probably OK after the build, it is just the /dev and probably others directories and files that do not come properly configured. If you compare the Zubuntu 2.0 tar achive /dev and the Angstrom /dev you will see that none of the Angstrom files in /dev have have been mknod. If Zubuntu just works after installing it on the SD card so there is no reason why Angstrom should not do the same. Unfortunately Zubuntu 2.0 is just not usuable on a Zaurus SL-C1000, it is way too slow, 5 minutes to start Fennec!

So I still want to try Angstrom and see if it is more usable. I tried it 2 years ago and it worked fine, but could never get my WiFi card to work so I kept Cacko because everything just works and it is fast. But now I need to have Apache and PHP on my Zaurus for working on a project while on the train.

Does anybody know how to install a fresh build of Angstrom on a Akita?

The last build I done should still be on the Angstrom server if anybody wants to try it on their Akita:
i haven't had much luck with angstrom. I don't think that they care much about Zaurii anymore. you can always try asking in the angstrom forum, but if you want a real chance of a reply, i would try their mailing list.

if you are looking for a somewhat modern distro to try, Andromeda was pretty nice, is Debian based. In fact i may go back to it instead of zubuntu.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.