Help - Search - Members - Calendar
Full Version: java SerialPort program doesn't work on Z???
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Personal Java/Jeode/J2ME Personal Profile
liferey
I downloaded SimpleRead.java from

http://java.sun.com/developer/releases/jav...SimpleRead.java

It worked well on a linux desktop. But when I move it to Z, it said
"No /dev/ttyS0".... This java program couldn't find any CommPortIdentifier.

I got the comm.jar for Zaurus from
http://s88074083.onlinehome.us/Zaurus/Index.htm
and it is saved in /home/QtPalmtop/java/comm.jar. I am pretty sure ttyS0 is open because I can use a C program to read from it. What could be the problem?

I've searched all the messages and nobody's ever had this problem before. Am I missing some real obvious steps here? I will be forever indebted for your help!
jeff_burch
I'm having a related problem that is explained here: http://www.zaurususergroup.com/index.php?n...iewtopic&t=4495

If you solved this, could you please let me know?

Thanks in advance, Jeff
johnw
I've noticed some strange Java bugs with my 6000L that I didn't have with the Jeode JVM on my trusty old 5000d. Is it possible to just scrap the newer JVM & run Jeode on the 6000L? I wonder what the maximum screen resolution would be with Jeode. Anyone know? Is there an alternative (other than Jeode) that I can run on the 6000? Something less flakey?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.