Help - Search - Members - Calendar
Full Version: Sl-5500 Cradle Issues
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 Hardware
Hi guys!

Is it normal that when colie put in cradle and power, he lose usb conection with windows, but when disconect cradle from power -> i can conect normaly to desktop pc via usb?
Is it posible that some caps or something burned in cradle?

Your ROM could be a factor. This is tkcROM you have on the Collie?

Try running the following commands, both when Collie is and is not connected, and before and after attach cradle to power supply.


ifconfig -a

That can help debug what is going on. It is possible you may have to reconfigure from command line to get connection recognized.

Post results, they may be helpful to figure it out and get suggested solutions.

Rom is sharprom, but the same issue is with kompanyROM
Output with cradle connection, and without power
# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface   *        U     0      0        0 usbd0
default                        UG    0      0        0 usbd0
# ifconfig -a
irda0     Link encap:IrLAP  HWaddr 00:00:00:00
          NOARP  MTU:2048  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:8
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:275 errors:0 dropped:0 overruns:0 frame:0
          TX packets:275 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:21996 (21.4 Kb)  TX bytes:21996 (21.4 Kb)

usbd0     Link encap:Ethernet  HWaddr 40:00:01:00:00:01
          inet addr:  Bcast:  Mask:
          RX packets:173 errors:1 dropped:1 overruns:0 frame:1
          TX packets:125 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:18356 (17.9 Kb)  TX bytes:33470 (32.6 Kb)


Output with cradle connection, and power -> when i connect power immediately connection disapear and windows report under device manager "This device cannot start. (Code 10)"

Output without cradle and power connected:

ifconfig -a same such as with cradle, but whitout usbd0 connection

(I dont know comand in console to redirect output in file)
Which Sharp ROM? I use 2.38 and have never seen a device manager.

Have you tried simply restarting the usbd0 connection after plugging power in?

Command would be something like:

ifconfig usbd0 netmask up

Also, are you sure that is the right IP? I still get very confused about figuring out the right one, but maybe somebody else can help who knows more.

Meanwhile, try the above ifconfig command, and right after that, try your ifconfig -a

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.