I've got 3 chargers for my SL-C860 - the original world voltage one from Dynamism plus two others I've picked up on the way. I use one at work, one at home and the diddy little original for travel. A few days ago my two recent chargers refused to charge my Z. The jacks would go part way in but not snugly home - and not far enough to charge.

Nil desperandum! The original charger still worked fine. But what could be wrong with the other two??? It must be some mechanical fault in the Z's jack socket. Squinting in with a magnifying glass I couldn't spot any foriegn objects and the central contact was straight. Perhaps the side contact "leaf" has been bent out of position?

So, out with the watchmaker's screwdriver and strip off the back of the Zaurus. The DC jack socket has a slot down the side (to make its profile as low as possible) and it's easy to look through the magnifying glass at the side contact - perfectly OK. So what's the problem?

Then I noticed a yellow "collar" at the base of the central contact. It's almost 2mm thick and stops my charging connectors from going right home. Funny - it doesn't seem to belong there. I can slide it out with the tip of a scalpel. Once out, I see that it's the insulating tip/ring from the jack of my original charger, broken off whilst in the socket. Obscure or what? Anyway, problode solved - charging can resume at all locations!