Help - Search - Members - Calendar
Full Version: messed up Z's config, Japanese IM always on
OESF Forums > General Forums > General Support and Discussion > Software
patrick
I did something to my SL5500's setup last night which caused a Japanese inline input method to always be used for some apps, like the Qtopia PIM apps and Zeditor, but not others, like Hancom.

Oddly, all the resulting characters display as (red) squares, even though I uninstalled all the fonts except unifont and unismall.

I'm using the Sharp 3.10 ROM, and I have CRIM from the A300 ROM installed. Could CRIM be the culprit? It used to only activate when I selected it as the input method, and even then only as a bottom-line IM, not inline.

Does anyone have any idea what I did and how I might undo it?

thanks,

Patrick
patrick
I fixed it.

I think the problem was with CRIM, and I think the files fepgaku.ja and/or fepmode.ja.conf might be the configuration files for it (fep: front-end processor (for latin to japanese character conversion)).

fepgaku.ja was an empty file and fepmode.ja.conf had the following contents:


patrick
Beh! My previous post contained unfriendly non-characters which seem to have not uploaded properly. So I'll skip the gory details this time. I did this:

# cd /home/zaurus/Settings
# rm fepgaku.ja fepmode.ja.conf

and then rebooted. Afterwards the troublesome inline Japanese IM went away allowing me to once again type latin characters.

Patrick Charles Hayes
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.