Help - Search - Members - Calendar
Full Version: full emacs for zaurus?
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Linux Applications
hans
Has anyone tried cross compiling a full emacs (21) for the Zaurus? Are there obvious obstacles to doing so?
pitr
This is as far as I've got on my FC3 system (please bear with me, this
is my first attempt at cross-compiling an application):

First, I downloaded and installed binutils-cross-arm-2.11.2-0.i386.rpm,
linux-headers-arm-sa1100-2.4.6-3.i386.rpm,
gcc-cross-sa1100-2.95.2-0.i386.rpm, glibc-arm-2.2.2-0.i386.rpm

CODE
# Extract sources and configure them
tar -zxf emacs21.3.tar.gz
mkdir emacs-arm-build
cd emacs-arm-build

export PATH=/opt/Embedix/tools/bin/:$PATH
CC=arm-linux-gcc ../emacs-21.3/configure --build=i386-linux \
 --host=arm-linux --without-x

# Fix library paths
cd src
mv Makefile Makefile.orig
sed -e"s:/usr/lib/crt1.o:/opt/Embedix/tools/arm-linux/lib/crt1.o:" \
   -e"s:/usr/lib/crti.o:/opt/Embedix/tools/arm-linux/lib/crti.o:" \
   -e"s:/usr/lib/crtn.o:/opt/Embedix/tools/arm-linux/lib/crtn.o:" \
   < Makefile.orig > Makefile

# Make binary needed during compilation
make CC=gcc prefix-args
cd -

# Gather everything needed to build final emacs binary on the Zaurus
make; make
export SDIR=../emacs-21.3
export DDIR=../emacs-arm
mkdir -p $(DDIR)/{lisp,info,bin,etc}
cp src/temacs $(DDIR)/bin
cp $(SDIR)/lisp/*.elc $(DDIR)/lisp
cp $(SDIR)/lisp/{paths,loadup,loaddefs,version}.el $(DDIR)/lisp
cp -r /usr/share/emacs/21.3/etc/* $(DDIR)/etc


So, I happily copy the emacs-arm directory over to my Zaurus and run:

CODE
temacs -batch -l loadup dump


... and realize that there are paths from my desktop system hardcoded
into the temacs binary:

CODE
Warning: arch-independent data dir (/usr/local/share/emacs/21.3/etc/) does not exist
Warning: Lisp directory `/home/peter/src/emacs-21.3/lisp' does not exist.
Cannot open load file: loadup


Where do I go from here? Suggestions gratefully received. And better ways of cross-compiling Emacs would be even better!

(Also posted to comp.emacs).
pgas
For what rom/server?
for x/qt it is in the feed http://xqt.sourceforge.jp/feed/
I guess for debian it is readily available too.

For pdaxrom it compiles natively without trouble (you only need space and perhaps a swap)

The only "problem" is that you cannot (Afaik) cross compile it.
pitr
QUOTE(pgas @ May 8 2005, 04:05 PM)
For what rom/server?
*


C-3000 Sharp ROM. AFAIK the only other ROMs available for the C-3000 are OpenZaurus and Cacko, both of which would provide the same challenges to get it working. sad.gif
hans
I don't have any insight (still!) about cross compiling emacs. But I was happy to find an ipk for emacs that works with the X/Qt server at: http://xqt.sourceforge.jp/feed/ It works like a charm.
easyE
QUOTE(hans @ Jun 17 2005, 01:47 PM)
But I was happy to find an ipk for emacs that works with the X/Qt server at: http://xqt.sourceforge.jp/feed/  It works like a charm.
*


That's a great find! I have been looking for a full emacs for a couple weeks now. I assume that X/Qt refers to the X/Qt OZ ROM. You were running on a C7XX? Would this distro and package run on my 5600? I currently run the Sharp ROM that came with my 5600, but would happily switch (and am open to suggestions - but i don't want to take us too far off topic, maybe a nudge toward a good discussion would be nice)

Like other emacs users, I try to do nearly everything withing its friendly confines cool.gif. Have you been able to test gnus, tramp, or calendar? What other interesting packages/modes have you been able to use?

Thanks again!

- dan
Cresho
c1000 and sharprom with xqt running emacs....iss possible. i had it running
DrWowe
EMACS has a very special build procedure that makes it difficult to cross-compile (it compiles parts of itself then uses some OS magic to dump its in-memory image to a file)

The Debian one is mayne the easiest one. I'm really appeciating PocketWorkstation, it's put an end to most of porting hassles.
miskinis
I use the EMACS that Pgas built for pdaXrom. A few days ago I even got
cc-mode working (downloaded from sourceforge, and built with LISP), with
full C code syntax coloring/indenting, and performed some customizations, to
eliminate the toolbar, menubar, scrollbar, change the colors of many things,
added some keybindings, etc.. I displayed the calendar, but I never have tried to
interact with it.

I will post a screenshot or two if anyone is interested within a few days,

John
bam
I have seen micro-emacs for stock
ShiroiKuma
There is full Emacs22 (Unicode version) available for the Sharp ROM as well as for pdaXrom at: http://www.focv.com/ipkg/

The top package has console support and X support, to be run in X/Qt.

The second package from the top is only for console, if you don't intend to use X/Qt to run Emacs.
bam
I picked it up, looks kinda nice, but I need a crib sheet for the key combinations for the zaurus
ShiroiKuma
I wonder if any of you Emacs users have seen the problem I have with the above mentioned version of emacs on the Z. Everything is fine, but when running M-x shell, and listing directories, the output is garbled like this
Click to view attachment

Does anyone know how to fix this?
pgas
(add-hook 'shell-mode-hook 'ansi-color-for-comint-mode-on)

in your .emacs

http://www.gnu.org/software/emacs/manual/h...ll-Options.html

(or use ansi-term)
ShiroiKuma
Thanks a lot. Works great! smile.gif
telemetric_au
CODE
# Fix library paths
cd src
mv Makefile Makefile.orig
sed -e"s:/usr/lib/crt1.o:/opt/Embedix/tools/arm-linux/lib/crt1.o:" \
   -e"s:/usr/lib/crti.o:/opt/Embedix/tools/arm-linux/lib/crti.o:" \
   -e"s:/usr/lib/crtn.o:/opt/Embedix/tools/arm-linux/lib/crtn.o:" \
   < Makefile.orig > Makefile



very handy, and a higher level of portability, rather than what i was trying to... (just copy the files there...)

just watch out you dont do a make clean or distclean after editing like i did a few times... wink.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.