Help - Search - Members - Calendar
Full Version: Makeing the Z a nice mp3 player
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
jgraves
Ok. So you have xmms running. And you installed my little screen blanker utility to turn of the screen. Now you can close the top and listen to your music. But... Now you want to pause/play/forward/reverse... The side buttons don't really work!

The roller knob does a fast forward & rewind 5 seconds. Nice, but not
very useful. With only 4 buttons (roller forward/back, ok, cancel), I wanted
to re-map these keys whenever I run xmms. No problem.

Make the following file:
/etc/X11/kb/xmms.xmodmap
---------------
keycode 131 = X
keycode 132 = C
keycode 133 = B
keycode 134 = Z
---------------

Create an xmms wrapper file:
/usr/bin/xmmsWrapper.sh
---------------
#!/bin/bash
xmodmap /etc/X11/kb/xmms.xmodmap
xmms
xmodmap /etc/X11/kb/corgi.xmodmap
---------------

Change the launcher to use the wrapper file.
Edit:
/usr/share/applications/xmms.desktop
Change line:
Exec=xmms
to
Exec=xmmsWrapper.sh

Restart X (Is there a better way to tell matchbox to re-read?)

That's it.

Now, when you run xmms, you can turn off the screen and
close it. Now they keys are mapped to:
OK = Play
Cancel = Pause
Dial Forward = Next song
Dial Backward = Prev song

Note: the xmms app must be "active" when you close the Z
This is the default after you launch it, but if you are messing
around with something else, be sure to click on xmms before
closing the lid.

Have fun.

-John
C760 - My $700 mp3 player! biggrin.gif
padishah_emperor
You've just answered what I was about to ask! :-)

How about mapping the dial to volume +/-
jgraves
I thought about that. My headphones have a volume, so I didn't
see a real need (for me). Plus, I don't think it would be trivial.
I don't see any xmms shortcuts for volume. So, the keys would
need to be mapped to execute some command line app to adjust
the volume. I don't even know how to adjust the volume from
the shell. Anyone know?

-John
Reaper
I suppose that Z remote control support would be Really Nice Thing (Qtopia Music player does have it, after all).
[/list]
newkirk
QUOTE
I don't see any xmms shortcuts for volume.  So, the keys would
need to be mapped to execute some command line app to adjust
the volume.  I don't even know how to adjust the volume from
the shell.  Anyone know?


Haven't reinstalled xmms on the 860 since reflashing to the new release ROM, but on my 5600 I've always used the cursor ring - left/right are skip track, and up/down are volume.

Try mapping to the up/down cursor keys.

j
padishah_emperor
keycode 131 = X
keycode 132 = C
keycode 133 = Up
keycode 134 = Down

But if the Volume applet is running, this don't work. When run from xterm you can see it's because /dev/mixer is busy, shame. But it's a solution, I prefer volume control via the dial.

Got the idea from this thread
http://www.zaurususergroup.com/index.php?n...iewtopic&t=3230

Thanks for the pointers jgraves, newkirk

;-)
jgraves
Great stuff. Thanks for the up/down tips.

I think the idea of mapping different functions to the external
buttons for different apps will come in handy in the future.

-John
padishah_emperor
I've just got the Audio Remote Control (CE-RH1) working in pdaXrom, follow the initial instructions above.

The file /etc/X11/kb/xmms.xmodmap should read:

keycode 104 = Up
keycode 105 = Down
keycode 106 = B
keycode 107 = Z
keycode 108 = C
keycode 109 = X

You will need the main window of XMMS active, you will find that Play on the remote will play but not pause as in Qtopia, the Stop button acts as a pause/resume.
Reaper
Thanks a lot! biggrin.gif But forward/rewind buttons don't work fully, they just change songs, but don't scroll through it. Any workarounds?
padishah_emperor
Are you sure the main window of XMMS is the active window? Not the equaliser or playlist. Let me know, it should work.

Remember to execute the xmmsWrapper.sh as detailed above.

You are welcome to send me a private message if you want to go through it in more detail.
bastichelaar
Why doesn't my XMMS work? I installed it, but it won't play any file... It looks like it plays, and I do hear some clicks, but it doesn't play smoothly...
padishah_emperor
QUOTE(bastichelaar @ Jun 24 2004, 04:10 PM)
Why doesn't my XMMS work? I installed it, but it won't play any file... It looks like it plays, and I do hear some clicks, but it doesn't play smoothly...

Sounds to me like something isn't installed. I'll help if I can, list all the appropriate xmms packages you downloaded and installed, you may have missed something.
amrein
Just 2 cents...

Be carefull everyone in this thread. A few fools think that the Zaurus is not to be think like a multimedia PDA but like a old vt100 terminal. Be careful... ph34r.gif

MP3, Video, PIM, Synchronisation.... all this are bad for vt100 terminal.

Bad boys !
padishah_emperor
blink.gif

no

er..

no... sorry I don't get it... another dig at someone?
Reaper
Emperor, no need to worry about the absence of song scrolling. I'm content with my remote control as it is, because I reflashed my Z to X11 ROM in November and since that time I haven't been able to use it. But now these days are over, thanks! wink.gif
padishah_emperor
(blush)
You're most welcome biggrin.gif
Sna
Hi
i have also a problem with Xmms, it can't play mp3, i've 1 sec song 1 sec nothing :/

i've tried to disable the spectrum analyser, i've disabled the song scrolling, but absolutely no effect (i'm using Xfce4 but i've the same problem under openbox)
as you already have asked the package installed for xmms
all from the stable feed of pdaxrom.org
glib 1.2.10
gtk 1.2.10
mad 0.14.2b
xmms 1.2.10

i have the same problem with video playing, video plays smoothly when -nosound but with sound it is unviewable lol

anyone an idea? smile.gif

thanks in advance
Reaper
Try installing mad-devel. wink.gif
padishah_emperor
QUOTE(Sna @ Jun 28 2004, 08:43 AM)
Hi
i have also a problem with Xmms, it can't play mp3, i've 1 sec song 1 sec nothing :/

i've tried to disable the spectrum analyser, i've disabled the song scrolling, but absolutely no effect (i'm using Xfce4 but i've the same problem under openbox)
as you already have asked the package installed for xmms
all from the stable feed of pdaxrom.org
glib 1.2.10
gtk 1.2.10
mad 0.14.2b
xmms 1.2.10

i have the same problem with video playing, video plays smoothly when -nosound but with sound it is unviewable lol

anyone an idea? smile.gif

thanks in advance

If you are running mplayer from a console add:

-ac mad

See if that helps

For xmms you also need:

xmms-mad which also needs libmad and libid3tag
xmms-tremor which also needs tremor
Sna
thanks, xmms works nice now smile.gif i can listen all i want smile.gif

but for mplayer it's more complicated, with -ac mad i've no sound
then no change .. sad.gif
here is a copy of the output of the sound part of mplayer

Opening audio decoder: ffmpeg / libavcodec audio decoders
audio : 22050 Hz, 1 ch, 16 bit (0x10), ratio : 2519->44100 (20.2 kbit)
Selected audio codec: ffwmav2 afm : ffmpeg (DivX audio v2 (ffmpeg))

here for normal launch

and here for a mad launch

Forced audio codec: mad
Cannot find codec for audio format 0x161

but i have mad, libmad installed...
padishah_emperor
QUOTE(Sna @ Jun 28 2004, 08:18 PM)
thanks, xmms works nice now smile.gif i can listen all i want smile.gif

but for mplayer it's more complicated, with -ac mad i've no sound
then no change .. sad.gif
here is a copy of the output of the sound part of mplayer

Opening audio decoder: ffmpeg / libavcodec audio decoders
audio : 22050 Hz, 1 ch, 16 bit (0x10), ratio : 2519->44100 (20.2 kbit)
Selected audio codec: ffwmav2 afm : ffmpeg (DivX audio v2 (ffmpeg))

here for normal launch

and here for a mad launch

Forced audio codec: mad
Cannot find codec for audio format 0x161

but i have mad, libmad installed...

Sna
Sorry, I haven't checked this thread for a while, if you are still having mplayer problems and you haven't started a new thread about it, PM me and I'll see if I can rattle my brain for some ideas.
laugh.gif

As a test try a standard MPEG-1 encoded video, it could be that you are playing a video with a sound encoding for which there is no decoder. I don't know if the mplayer on pdaXrom is DivX audio compatible, I only use MPEG-1 and wmv so far.
Sna
no problem for time, this is a forum after all smile.gif

i've still problems with mplayer
but for a test i'll try all videos i have smile.gif
i'll send you a pm with results

thanks again for help smile.gif
Reaper
By the way: did anyone suceed to play MIDI files with XMMS? I haven't been able to compile XMMS MIDI 0.03 plugin because it required either hardware sequencer in /dev or timidity which is, AFAIK, unavailable for pdaX. What can I do to solve this problem?
Reaper
A sad thing discovered... This method & remote don't work with 1.1.0 RC2... sad.gif I've tried everything - rebooting and so on... The only possible matter I can suspect besides of ROM - I've installed cronyx-fonts and crox-cyrrilic package, but such things (not exactly the same) haven't interfered with remote till I reflashed my Z... Please, suggest anything...
Reaper
My remote works again with RC3. Thanks pdaX team!
Martin
THANKS very much to all ... remote works great with wrapper ... hope to get this inluded in 1.1.0 release :-)

But what about volume and right/left controls in xmms ... they don't work ... volume works only with wp-applet-volume ... :-( remote volume does not work too :-(

Thanks for any help
Martin
totaln00b
Hi All,

I have tried to implement the remote headphones mapping, but for some reason I cannot get it to work. I'm pretty certain I've followed all the instructions exactly, including restarting xwindows, but still it doesn't work. I'm using fluxbox (with pdaxrom rc5) and I'm wondering if there's something different that I should be doing to make it work- ie should I be changing something other than xmms.desktop to make it work?

Basically I can run xmmsWrapper.sh from xterm and the keymap works, but if I launch xmms from it's icon then it doesn't work. I can add the map to my xinitrc file and it works, so is it OK for me to leave it like that or can anyone tell me what I might have missed?

Thanks

Jo
pgas
Did you modify the /usr/share/applications/xmms.desktop ?

If not then change the line Exec=xmms to Exec=xmmsWrapper.sh
and it should work also from the icon.

(and if you have time please add a page about that on the wiki)

pgas who likes wikis!
totaln00b
QUOTE
Did you modify the /usr/share/applications/xmms.desktop ?

If not then change the line Exec=xmms to Exec=xmmsWrapper.sh
and it should work also from the icon


Yeah, did that...

Thanks

Jo
allyrfriends
QUOTE(totaln00b @ Feb 3 2005, 09:28 AM)
I'm using fluxbox (with pdaxrom rc5) and I'm wondering if there's something different that I should be doing to make it work- ie should I be changing something other than xmms.desktop to make it work?
*


If you're using vdesk instead of Matchbox Desktop, and running xmms from there, you need to change the 'Command:' line in ~/.vdesk/XMMS.lnk, not xmms.desktop.
totaln00b
Aah,

And if I'm running fluxbox on it's own I can just change the menu in .fluxbox! Silly me.

Thanks

Jo
allyrfriends
QUOTE(totaln00b @ Feb 3 2005, 12:43 PM)
Aah,

And if I'm running fluxbox on it's own I can just change the menu in .fluxbox! Silly me.

Thanks

Jo
*


Yep. You're welcome!
rdwtux
Incase people don't have headphones with volume control (like me) these settings in /etc/X11/kb/xmms.xmodmap might work better.

keycode 131 = B
keycode 132 = Z
keycode 133 = Up
keycode 134 = Down


This make OK/Cancel skip to next song, back one song and maps UP/Down to Volume.
papercrane
Aha, I think here are the keycodes I was looking for. However, I'm not sure which is which from this. If someone could let me know which keycode belons to which button that would be great. See my recent topic in the OZ/GPE forum.
Glaive
It seems that the keycodes for the C3100(possibly C1k/C3k) Ok/Cancel buttons are different:
Cancel is 102, Ok is 92
So my xmms.xmodmap looks like this:
//
keycode 102 = C
keycode 92 = B
keycode 133 = Up
keycode 134 = Down
//
i.e cancel is play/pause, ok is forward, up/down is volume up/down
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.