Help - Search - Members - Calendar
Full Version: Waking up Zaurus with at command
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Linux Applications
Nell
Hello,

I am having trouble settings up alamrs on Zaurus via at command. A file is created in the /var/spool/at, however the Zaurus is never woken up. What might be the problem?

Thank you for your help.
dino
It would help if you posted which ROM your using and what your at command is. I wonder if it's a time zone problem?
Nell
This is the command that I execute from the terminal

at -f "fileName" 11:30 4/13/2004

after I do this I see a file created in /var/spool/at. However, the alarm never goes off. It is probably not a time zone problem, since the calendar alarms go off. I'm using Zaurus 5500, not sure what ROM that has.

Thanx for the help.
Ethereal
On my 5600, the system time is UTC, but on everything in QTopia, it's corrected to local time. So setting an alarm for 11:30 in the calendar app might not be the same as setting one manually.

Also, where did you find info on the at command and setting wakeup events? This is one half of my quest to get email automatically.
Nell
You can find info on at by reading the script /home/QtPalmtop/bin/at

So, you think if I set the alarm in UTC time rather than local time, it should work?

Thank you.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.