Help - Search - Members - Calendar
Full Version: I've killed my OpenZaurus!
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
Izydorr
Here is what happened:
I have OpenZaurus 3.2 installed on my Zaurus 5500. I' ve bought a 256 SD card and wanted to install some things on it. I formatted it to ext2. Next I installed Jeode on it (downloaded from some feed) and then I installed Zaurus Sky Explorer on this SD (full version). When it was done I tried to run the sky explorer but nothing happened for long time (except blinking icon). So I tried to run console, file manager but nothing worked! Opie was responding, because I could use menu and check the battery using the applett. Shutdown didn't work, so I had to reboot using the battery replacement switch. After I've done this My OZ is dead! sad.gif( No matter how I restart it (I' ve even tried taking out the battery) it doesn't want to start. All I get is the starting screen with the dragon, OpenZaurus written below and a blinking cursor in the lower left corner.
Please anyone help me! Right now my only idea is to flash my Z again, but I loose all data and programs then sad.gif(((
Did anything like this happen to any of You?
I will be very grateful for any help.
Anonymous
Hi Daniel

I had a similar experience with a 1GB microdrive formatted ext2.

What I did is to check the file system with 'e2fsck -y /dev/hda1' or 'fsck /dev/hda1'. But beware, if you enter 'y' (for yes) this can definetely damage you file system.

If you lose data you can try to re-gather them at the card's lost+found directory. (/mnt/cf/lost+found)

It also is possible, that your Z just tries to perform his own fsck at the boot time which might take a while. After some minutes (5-10 min) it might boot regularly if you wait patiently.

A 3rd way may be to perform a file system check in your linux pc's card reader (e.g. 'e2fsck -y /dev/sda1', where /dev/d/sda? must be adopted to your PC's conditions)


Hope this helps

Georg
Izydorr
1. What do You mean by /dev/hda1??? If You mean Zaurus' memory I can'y do it because it doesn't boot at all.
2. Well that's what I thought, I mean that fsck is being run and that's why it lasts so long, but I'm waiting and waiting and nothing happens sad.gif
3. I don't have any reader for the card, but I tried too boot Zaurus without the SD card inserted and it still doesn't work.
Anonymous
/dev/hda1 - This is the CF card (first partition thereof in fact) which is where the microdrive is mounted. Your sd card would be /dev/mmcda1, but as you say, you can't get your Z up and running anyway so this is a mute point.

You say you've tried booting without any cards and it still doesn't work. Not a good sign imo, what you describe is identical to what happens when a flash goes wrong.

That said, although you've taken the battery out, the backup battery may have protected the memory. I'd try pressing in the hard reset button (inside the battery compartment), then try starting up again (cross fingers).

If that doesn't work, though I'm not sure, I would guess that your only course of action is to reflash, though I really can't see that you've done anything to harm the base system so I'm a little confused.


Si
lardman
That was my post, didn't realise I'd not been logged in.

Si
Izydorr
I've tried all known to me boot or restart methods before I've taken out the battery, that is Home + B, switching the battery replacement switch, pressing the hard reset button. All these didn't work sad.gif
And believe me: your confution isn't as big as mine smile.gif
I'm getting used to the thought that it all has to end with flashing Z sad.gif
Thanks for Your answers. I don't have a CF card, so I can flash when I will borrow it, so we still have a few days for trying, so if ANYONE has ANY idea I'm ready to try.
By the way, I turned my Z on and waited in hope that it's just some fs check that lasts so long, but after about 1 hour I gave up sad.gif (I've tried this with and without the SD card)
offroadgeek
I think you'll find that if you go out and buy a CF card (even a 32mb), and try to re-flash, you'll not only be much happier with a clean flash, but save a bunch of time!
Izydorr
It's aliiiiiiiiiveeeeeee! smile.gif
I just wanted to share my joy of being owner of fully functional Z again (after flashing it).
By the way I switched from 32-32 ROM to 48-16 since I have a SD card now.
Thanks everyone for Your help.
Anonymous
I have a sl-5500 just flashed the rom to 3.10 from there every went wrong. I tried to boot and I did. I got this message version 2.78 booting
init: no inittab file found
init: entering runlevel: 5
init: no more processes left in this method

what can I do to get the os working?
offroadgeek
guest - are you saying that you tried flashing to the sharp 3.10 ROM? if so, how did you perform the flash? ie. via ospack and CF, via initrd.bin and zImage and CF, or via sharp updater/usb?

offroadgeek
Anonymous
via sharp updater usb , new to this so I might have went the wrong way.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.