Help - Search - Members - Calendar
Full Version: Internet sharing Mac osx
OESF Forums > General Forums > Desktop Operating Systems Issues > Mac Issues
keef
Hi

I am trying to set up internet sharing through usb.
I have turned on sharing on the mac. Not sure if I need to run the network to the Zaurus first as I normally do or the Z will grab the internet connection.

Do not seem to have any options for usb connection in network prefs -everytime i try and connect it goes straight to irda connection -even with dummy dev installed.

Not really sure what to try next as all the how tos I have read refer to windows and generally say type in a few lines of code and it should work.

Is it possible to reset the network prefs back to default as I think I may have messed them up.

Thanks in advance for any help.

Ps I have c860 with the sharp Rom and panther on the Mac-connects fine with network and usb.


keef
freizugheit
I am a SL-5600 user. I use the USB driver at http://www.lucid-cake.net/osx_zaurus_usb/index_en.html to establish Ethernet linkage. It presumed that Zaurus is inserting in the docking station which is connected to Mac's USB port.

After that, I try pinging individual machine, whereby Mac is assigned 192.168.129.1 and Zaurus 192.168.129.201.

If the pinging is Ok. Please proceed to issue the following command with root access:

route add default gw 192.168.129.1

Type "route" to check whether the route table.

Activate your browser to surf the Internet.

I hope the above will help.
keef
Hi
Thanks for the reply
I can connect and ping the mac on 192.168.129.1 ok.
However when I try the browser it says cannot find the device card for communication.
The e-mail app does the same.
I have tried installing dummy dev but the machine reads this as irda not a usb connection.

keef
freizugheit
Which Zaurus are you using and which OS is in use?

Have you checked the route table?
keef
Hi


I am using C860 with the original sharp rom.
Linux Kernel 2.4 18-rmk7-pxa3-embedix
ROM Version: !.10 JP

I have Panther installed on the Mac.

This is the readout from the console:

bash-2.05$ su
# route add default gw 192.168.129.1
# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.129.0 * 255.255.255.0 U 0 0 0 usbd0
default 192.168.129.1 0.0.0.0 UG 0 0 0 usbd0
#

keef
freizugheit
I hope your C860 also has PC-Link application.

Try the following:

Make sure that the Zaurus is in the docking station.
Activate PC-link and check USB (IO-default) is selected, click OK to quit.
Activate PC-link again, now select USB (TCP/IP advacned) option and click OK to quit.

I hope the above might help.

By the way, with the above instructions, you can mount your Zaurus on Mac's desktop using SMB.
Ovi
Hi
you should check also if you're using a DNS server for your mail. This should be added in /etc/resolv.conf on your zaurus.
keef
Thanks
I do have Pclink it works fine and mounts on the mac desktop no problem.

I checked the file /etc/resolv.conf.
says: Domain name searches will fail until you point this to a real DNS server.
nameserver 127.0.0.1
Tried to edit this but text editor will not allow any changes?
Shoud this not be entered somewhere in network prefs?

keef
Ovi
Hi
I did it using (as root) "vi" and it was working!
freizugheit
keef,

Please check whether you have activated Internet shaing uisng Sharing under System Preferences.
keef
Success!!!

I have managed to connect and send recieve email.

I edited the file as Ovi suggested --thanks.

(I have sharing enabled on the Mac)

Still cannot connect with browser -get tcp connect error although I have
entered the info into the Dummy Device pane?

Does this involve editing another file?

Is it possible to downloadOpera to run on C860?

Thanks again


keef
asfrank16
i am still having problems with internet sharing. I have installed dummy dev but not sure I have configured it correctly. I have entered an ip (the one the Zaurus uses and said to automatically detect the DNS server names. I left the account information blank. It says it connects, but then it disconnect within 2 minutes or so and I cannot connect to the internet, or get email. How should this be configured (I have also tried to use my account info for my mac in the account info part, to no avail).

In the resolv.conf file, how do I know what to put there as well?

Thank you.

-Adam Frank
keef
hi

I found after much agonising that I did not need to put any information in the dummy dev preferences.
Basically left everything blank except dns servers of my internet provider.
entered these also into the resolv.conf file as:
nameserver xxx.xx.xxx.xx nameserver xxx.xxx.xx
(replace these xxs with your dns servernumbers.)


keef
freizugheit
asfrank16,

Have you followed my steps in checking and pining IPs of both machines, ie Zaurus and Mac via the USB docking station?
Which Z is in use and ROM version?
The USB driver assigned 192.168.129.1 and 192.168.129.201 to Mac's and Zaurus's USB port.

Try at terminal from Mac "ifconfig > if.txt" and post the content of if.txt here.
asfrank16
Keef, I tried to configure everything that way, no good. But thanks.

Freizugheit, I am able to ping both ways (did try this) I have a C700 with the cacko rom

here is the print out:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::230:65ff:fea4:31b4 prefixlen 64 scopeid 0x4
inet 192.168.1.42 netmask 0xffffff00 broadcast 192.168.1.255
ether 00:30:65:a4:31:b4
media: autoselect (100baseTX <full-duplex>) status: active
supported media: none autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback>
fw0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 2030
lladdr 00:30:65:ff:fe:a4:31:b4
media: autoselect <full-duplex> status: inactive
supported media: autoselect <full-duplex>
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::3630:30ff:fe30:3000 prefixlen 64 scopeid 0x6
inet 192.168.129.1 netmask 0xffffff00 broadcast 192.168.129.255
ether 34:30:30:30:30:00
media: autoselect (10baseT/UTP <full-duplex>) status: active
"if.txt" 22L, 1322C
keef
Try adding the command:
route add -host 192.168.129.1 usbd0
this should direct the connection through usb.

keef
freizugheit
asfrank16,

Please check whether you have activated Internet shaing uisng Sharing under System Preferences.

You need to modify your /etc/resolv.conf to include nameserver and IP there.
asfrank16
How do I put the IP in the resolv.conf? I do have internet sharing on.
asfrank16
What I meant to ask was not how (i know how to edit the file) but what syntax do I use in the file to specify the IP address
freizugheit
Maybe you can post the content of /etc/resolv.con of Zaurus here.
asfrank16
Sorry for the delay in responding.

the contents are as follows (I did not opy the warning about having to point to an actual nameserver):

nameserver 199.45.32.43
nameserver 199.45.32.38
freizugheit
asfrank16,

By reading your ifconfig output posted on 29/4, it looks like your Mac was not connected to Internet directly.
Maybe let us know how you connect to the Interne, are you using another computer as a gateway.
asfrank16
I am connected through the network (dsl router). The DSL router is part of the network router. The info entered as the nameserver is what my computer uses to connect to the network, not what the router uses to connect to the internet (if that makes sense).

-Adam
freizugheit
asfrank16,

On the Mac's System Preferences, click Sharing and press Internet tab.
Select Buitl-In Ethernet follow by pressing the Start button.

I hope this will help share your built-in ethernet interface en1.
ericwerk
It cost me some sweat as well, but i have it working. You can find a nat how-to on the following address:
http://www.mac-im-netz.de/MacOSX-NAT.html
The first part is in german, but it basically says that in /etc/hostconfig you need to change the IPFORWARDING=-NO- line
to IPFORWARDING=-YES-

than just do what the rest of the how-to says, putting the three files in the /System/Library/StartupItems/NAT folder (make the folder if it doesn't exist) . And freizugheit's tip about checking if you have sharing allowed in the system's pref network panel is very important as well (I wish I would have read that before stumbling upon it)

Then on the zaurus type

route add -host 192.168.129.1 dev usbd0
route add -host 192.168.129.201 dev usbd0
route add default gw 192.168.129.1 dev usbd0

(not my idea these, also googled them from somewhere)
asfrank16
Thank you all who helped. I now have access via my mac to email and the web. Thank you.

-Adam Frank
freizugheit
asfrank16,

Can You share the steps or configurations you have done with us?
asfrank16
I used the steps outlines by ericwork above exactly (I had to create the directory and three files myself). Then I was able to connect. I also think part of my problem was that I had the power saving features on, which terminated the connection whenever the mac went into power save mode (although this IS NOT what stopped me from connecting originally). Hope this helps.

-Adam
Ovi
Hi
I tried also to acces my mail from my SLA-300 using the shared MAC ethernet but it does not work. I have sharing enabled on my Mac, the correct gw on my zaurus, the correct DNS server on my zaurus and the NAT modifications on my Mac. I can even ping the DNS server but when trying to get the mail it always complains about "unknown host". Bellow I attached the output of "ifconfig" on my Mac:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::20a:95ff:fecf:6bea prefixlen 64 scopeid 0x4
inet 141.xx.xxx.x netmask 0xffffffc0 broadcast 141.xx.xxx.xx
ether 00:0a:95:cf:6b:ea
media: autoselect (100baseTX <full-duplex>) status: active
supported media: none autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <
full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 100baseTX <half-duplex> 100ba
seTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 1000baseTX <full-duplex>
1000baseTX <full-duplex,hw-loopback> 1000baseTX <full-duplex,flow-control> 1000b
aseTX <full-duplex,flow-control,hw-loopback>
fw0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 2030
lladdr 00:0a:95:ff:fe:cf:6b:ea
media: autoselect <full-duplex> status: inactive
supported media: autoselect <full-duplex>
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet 192.168.129.1 netmask 0xffffff00 broadcast 192.168.129.255
ether 34:30:30:30:30:00
Ovi
Hi
On my home setup where I share between my mac and my zaurus the modem line (dynamic IP) I can easily acces the internet from my zaurus even without the NAT files installed (just sharing from System Preferences and add the mac as a default gateway on my zaurus).

On my work setup I have a static IP for my computer and it uses a gateway somewhere on a central server of the lab to acces the net.[/i]
freizugheit
You need to modify your /etc/resolv.conf to include nameserver and IP there.
Ovi
which IP ?
Of my mac? Of the gateway that my mac uses?
freizugheit
Nameserver of your ISP through which your company connects to Internet.
Ovi
I found out why my internet sharing was not working on my mac with static IP. The firewall was enabled and it seems that is blocked the protocols that the mail on zaurus was using. As soon as I disabled the firewall I could acces my mail from my zaurus. Now the question is how to enable the firewall to not kill the zaurus internet connection?
:?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.