Help - Search - Members - Calendar
Full Version: Kismet compiled and ready for pdaXrom
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Laze
Kismet is now compiled and working. Download it from our IPK feed and also have a look at the Kismet FAQ section. Together Kismet and pdaXrom makes your Zaurus the best wifi sniffing tool ever.

You can find the file at our feed.

Please report any bugs and problems with kismet in this forum and not on the bug reporting page on www.pdaXrom.org
ScottYelich
How many people are compiling things for the pdaXrom -- do you have the user-area upload feed in any level of working order?

Scott
Laze
Scott - we are working on making a public/untested ipk feed - actually i have just completed the first complicated procedures :-) So please have patience and we soon be ready with that. Until then you can e-mail me updates and ipk - we wan't to test stuff before putting it online
Talyinka
Excellent - I was working at that yesterday but didn't get it finished. I'll try the new binary asap and give feedback if any. 8)
newkirk
I installed it, and it works beautifully with my Ambicom wifi.

However, not only does it not work with my Socket card (no shock, just disappointment wink.gif), after installing and playing with Kismet my WLAN connection no longer works correctly, despite reconfigurations and reboots. (although Kismet continues to work, with the Ambi) The cards power up and start blinking their 'offline' pattern with the LED. A subsequent "ip l s eth0 up" brings up the connection, however.

Also, although the network.opts and wireless.opts files are still there, and appear to have correct settings, and when I 'apply' from the LAN applet it saves the changes, whenever I launch the LAN applet it comes up blank - all fields empty.

Did I simultaneously break networking and install kismet, or is this all related?

j :cry:
Laze
Newkirk: I normal run:
cardctl scheme CardResume
kismet
cardctl scheme Normal
and maybe also a:
/etc/pcmcia/network start eth0
hwkeye
It seems did not work with Linksys WCF12
Laze
hwkeye: Try a lsmod and post the output here and a iwconfig too - try editing the kismet.conf in /usr/etc/ - try different settings for source eg:
source=hostap,eth0,hostapsource
source=orinoco,eth0,orinocosource
hwkeye
Hi Laze,

lsmod give me :

Module Used by Tainted
orinoco_cs 1
orinoco 0 [orinoco_cs]
hermes 0 [orinoco_cs orinoco]

I remember under Qtopia sash tongue.gif we have a config file called
wlan-ng.conf
Do you think it is missing in pdaXrom and it is why for making my wireless card work I have to execute those commands:
#iwconfig eth0 key MY_WEP_KEY open
#iwconfig eth0 ESSID MY_ESSID_NAME

thanks for your help.
hwkeye
Thanks Laze,

I unremark orinoco driver and it seems to work.

But I got some problem about suid user. I have following kismet FAQ section in www.pdaxrom.org

in kismet.conf, suiduser=kismetusr

I launch kismet and I got an error message about permission file denied for a file .dump

Do you know what can I do ?
hwkeye
Hi all,

Ok now it works.

I have to create the directory for LogTemplate
tz
One other possible problem with the current kismet and the socket CF card.
The original Spectrum card needed a usleep call between each of the calls to set monitor mode and channel in pcapsource.cc. There are more calls now, and (on my card) I had to insert more usleep(5000) calls.
If pdaXrom is using an updated driver or wireless config calls, it might work without these.
daeos
what settings would i use for a SL-6000L ? I tried the example :

source=prism2,wlan0,prismwsource,2

and just got an error:

# kismet
Server options: none
Client options: none
Starting server...
Waiting for server to start before startuing UI...
Will drop privs to xxxx (501) gid 501
No specific sources given to be enabled, all will be enabled.
Enabling channel hopping.
Enabling channel splitting.
FATAL: Unknown capture source type 'prism2' in source 'prism2,wlan0,prismwsource,2'
Capn_Fish
I don't know if the 6000 uses HostAP, but you could try using "hostap" or "orinoco" as the source type.
daeos
QUOTE(Capn_Fish @ Jul 2 2008, 11:47 AM) *
I don't know if the 6000 uses HostAP, but you could try using "hostap" or "orinoco" as the source type.


Ok thanks man, Oh and I got it working, using a how to i found for the SL-6kL and now the wifi works great. I saw you had a feed up... and working too.. but one problem with it, I added pidgin and i can't run it as i need a lib thats not listed in your feed. could you add libpangocairo-1.0.so.0 ? or am i not configuring it right?
Capn_Fish
Just remember that my feed is mostly built on pdaX r198, so things may not work well or at all under Beta 1.

Have you checked other feeds for it? I possibly got a package from one of them (or the pdaX main feed).

EDIT: http://distro.ibiblio.org/pub/linux/distri....0_armv5tel.ipk

Beta 1 Pango IPK
daeos
QUOTE(Capn_Fish @ Jul 3 2008, 08:15 AM) *
Just remember that my feed is mostly built on pdaX r198, so things may not work well or at all under Beta 1.

Have you checked other feeds for it? I possibly got a package from one of them (or the pdaX main feed).

EDIT: http://distro.ibiblio.org/pub/linux/distri....0_armv5tel.ipk

Beta 1 Pango IPK




Thanks for the beta 1 feed link, I added that to my feeds list. However, upgrading from 1.9 to 1.10 on pango did not get rid of the error message, I will try gaim instead and see how that works out. Is there an IRC channel for this project? I did not find one in freenode for pdaxrom .. prehaps one should be opened?



Edit :
libpangocairo-1.0.so.0 is still requested by the new packages it seems.... I'll see if I can find it.... not sure where though.

Capn_Fish
Check in /usr/lib and see if there's a "libpangocairo.so.x.x.x," then try linking it to libpangocairo-1.0.so.0
daeos
QUOTE(Capn_Fish @ Jul 3 2008, 06:08 PM) *
Check in /usr/lib and see if there's a "libpangocairo.so.x.x.x," then try linking it to libpangocairo-1.0.so.0



Its not in that directory, nor when i attempt updatedb and then locate libpangocairo do I find anything
Capn_Fish
I guess I'm out of ideas, then. I don't think I compiled any pango packages, but maybe I did. If so, they're lost now if they're not in my feed. Sorry. sad.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.