Help - Search - Members - Calendar
Full Version: GNURoot Debian and fonts
OESF Portables Forum > Model Specific Forums > Gemini PDA > Gemini PDA - Linux OS
salvomic
hi,
I installed GNURoot Debian in the Gemini (not rooted), then LXDE. The X Window starts well (with XSDL server: export DISPLAY=:0) but the fonts are too small, expecially those on the XTerm: how to set them to get them readable, please? I use Gnome and there is easier to do it...

Altogether, it is nice to use Debian (for now Jessie, 8, within a few days they should update to Stretch, 9) with the keyboard and a USB Microsoft mouse, a part of the fonts, ok for the menu but not in the terminal...

Salvo
vader
QUOTE(salvomic @ Jun 12 2018, 07:00 AM) *
hi,
I installed GNURoot Debian in the Gemini (not rooted), then LXDE. The X Window starts well (with XSDL server: export DISPLAY=:0) but the fonts are too small, expecially those on the XTerm: how to set them to get them readable, please? I use Gnome and there is easier to do it...

Altogether, it is nice to use Debian (for now Jessie, 8, within a few days they should update to Stretch, 9) with the keyboard and a USB Microsoft mouse, a part of the fonts, ok for the menu but not in the terminal...

Salvo


You can start an xterm with:

xterm -fa Monospace -fs 14

change 14 to whatever size font you want. You can alternatively edit your xresources file. I found the fonts under XSDL weird and not entirely consistent. The bottom bar is broken in the openbox-session (I am still messing with it). If you use the vnc server, then all the fonts are correct, but other things need attention (eg. background). Most apps can support font settings, you just need to find them and modify the shortcuts/menu items that start them. A bit of setup, but hopefully once you get it working, you won't touch it again.
ArchiMark
Salvo,

Did you follow me the directions on this page?

https://github.com/gemian/gemini-keyboard-apps/wiki/DebianTP

Hope this helps,

Mark
salvomic
QUOTE(ArchiMark @ Jun 12 2018, 07:05 AM) *
Salvo,

Did you follow me the directions on this page?

https://github.com/gemian/gemini-keyboard-apps/wiki/DebianTP

Hope this helps,

Mark


thank you Vader and thank you Mark,
I'll read that page and follow also the Vader advice.

Salvo
salvomic
Problem with Italian keyboard and GNURoot Debian: there is no dash "-". It should be made with FN+". :" key but that combination returns a "." (like "." key), I cannot find any other dash (a part of "_" underscore: FN+"M").
Any help?

EDIT: the same problem is in Terms Desktop Terminal (Openbox): no dash elsewhere
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.