Help - Search - Members - Calendar
Full Version: Dash symbol with Italian keyboard and Linux (not dual boot)
OESF Portables Forum > Model Specific Forums > Gemini PDA > Gemini PDA - Linux OS
salvomic
hi,
in my Gemini with Italian keyboard I have a problem with “-“ (dash symbol) in GNURoot Debian (X, graphic mode only), and also in Termux Desktop (Openbox): in XTerm there is not possible to get the dash "-".
It should be typed with FN+"." key combination in Italian keyboard (in English layout, if I'm not in error, it is FN+O): but that combination returns a "." (the same as the dot "." returned by the key without FN), I cannot find any other dash (a part of "_" underscore: FN+"M”).
I cannot type, i.e., apt-get or name -a ..., that's I cannot use graphics in Debian (inside Android, not rooted for now, I've not still installed dual boot).

Maybe the problem is that the Italian layout is not correct in those programs.

All is ok with Android, Termux, command line programs but not in XTerm (both Openbox and GNURoot Debian X).


Any help, please?

Salvo


PS:
It is surely a problem of the layout: I had a similar problem with another tablet (there the culprit was the slash "/", another important char), see here.
galodoido
QUOTE(salvomic @ Jun 12 2018, 10:13 AM) *
hi,
in my Gemini with Italian keyboard I have a problem with “-“ (dash symbol) in GNURoot Debian (X, graphic mode only), and also in Termux Desktop (Openbox): in XTerm there is not possible to get the dash "-".
It should be typed with FN+"." key combination in Italian keyboard (in English layout, if I'm not in error, it is FN+O): but that combination returns a "." (the same as the dot "." returned by the key without FN), I cannot find any other dash (a part of "_" underscore: FN+"M”).
I cannot type, i.e., apt-get or name -a ..., that's I cannot use graphics in Debian (inside Android, not rooted for now, I've not still installed dual boot).

Maybe the problem is that the Italian layout is not correct in those programs.

All is ok with Android, Termux, command line programs but not in XTerm (both Openbox and GNURoot Debian X).


Any help, please?

Salvo


PS:
It is surely a problem of the layout: I had a similar problem with another tablet (there the culprit was the slash "/", another important char), see here.


I had this problem when installing dual boot ( android + debian ) .
So, in terminal, with an external mouse I did the command man df and selected "-" with the mouse. So, with the middle button pressed ( in terminal ) I pasted "-".
It is not a good solution , only a remedy.
I did the same with "/".
I did pwd command in terminal and selected "/" with the external mouse and pasted it pressing the middle mouse button ( or the wheel button pressed ) .
After this I was able to get the updates and load the correct keyboard.
salvomic
QUOTE(galodoido @ Jun 12 2018, 08:04 PM) *
I had this problem when installing dual boot ( android + debian ) .
So, in terminal, with an external mouse I did the command man df and selected "-" with the mouse. So, with the middle button pressed ( in terminal ) I pasted "-".
It is not a good solution , only a remedy.
I did the same with "/".
I did pwd command in terminal and selected "/" with the external mouse and pasted it pressing the middle mouse button ( or the wheel button pressed ) .
After this I was able to get the updates and load the correct keyboard.


thanks!
I'm trying just now.
I hope however a real fix and I would like to know if this is also a problem with the XSDL X Server...

Salvo

EDIT: tried, but no luck, also 'cause here in Terminal dash is ok, it isn't ok in XTerm inside X, as there were two different layout: one for CLI and one for X...
galodoido
QUOTE(salvomic @ Jun 12 2018, 03:49 PM) *
QUOTE(galodoido @ Jun 12 2018, 08:04 PM) *
I had this problem when installing dual boot ( android + debian ) .
So, in terminal, with an external mouse I did the command man df and selected "-" with the mouse. So, with the middle button pressed ( in terminal ) I pasted "-".
It is not a good solution , only a remedy.
I did the same with "/".
I did pwd command in terminal and selected "/" with the external mouse and pasted it pressing the middle mouse button ( or the wheel button pressed ) .
After this I was able to get the updates and load the correct keyboard.


thanks!
I'm trying just now.
I hope however a real fix and I would like to know if this is also a problem with the XSDL X Server...

Salvo

EDIT: tried, but no luck, also 'cause here in Terminal dash is ok, it isn't ok in XTerm inside X, as there were two different layout: one for CLI and one for X...


Try my recommendation in xterm: not in terminal.
So, in xterm, with an external mouse I did the command man df and selected "-" with the mouse. So, with the middle button pressed ( in xterm ) I pasted "-".
It is not a good solution , only a remedy.
I did the same with "/".
I did pwd command in xterm and selected "/" with the external mouse and pasted it pressing the middle mouse button ( or the wheel button pressed ) .
After this I was able to get the updates and load the correct keyboard.
salvomic
QUOTE(galodoido @ Jun 13 2018, 03:27 AM) *
Try my recommendation in xterm: not in terminal.
So, in xterm, with an external mouse I did the command man df and selected "-" with the mouse. So, with the middle button pressed ( in xterm ) I pasted "-".
It is not a good solution , only a remedy.
I did the same with "/".
I did pwd command in xterm and selected "/" with the external mouse and pasted it pressing the middle mouse button ( or the wheel button pressed ) .
After this I was able to get the updates and load the correct keyboard.


I want actually follow your advice, yes, but first I need to solve another thing: in Debian here the fonts in xterm is too small: how can I change it? Then I'll try your tips.

Salvo
galodoido
QUOTE(salvomic @ Jun 13 2018, 03:43 AM) *
QUOTE(galodoido @ Jun 13 2018, 03:27 AM) *
Try my recommendation in xterm: not in terminal.
So, in xterm, with an external mouse I did the command man df and selected "-" with the mouse. So, with the middle button pressed ( in xterm ) I pasted "-".
It is not a good solution , only a remedy.
I did the same with "/".
I did pwd command in xterm and selected "/" with the external mouse and pasted it pressing the middle mouse button ( or the wheel button pressed ) .
After this I was able to get the updates and load the correct keyboard.


I want actually follow your advice, yes, but first I need to solve another thing: in Debian here the fonts in xterm is too small: how can I change it? Then I'll try your tips.

Salvo


First with an external mouse you open xterm . Then click and hold control key ( ctrl ) and also at the same time you click the second button(right button ) mouse ( in the black screen of xterm ). A menu will appear . So, select true type fonts. Now , the xterm is already large. So, you will create a file in your /home/user, a file named .Xresources ( nano .Xresources ).
You will put the lines below in .Xresources :

XTerm*faceName:terminal
Xterm*faceSize:18
UXTerm*faceName:terminal
UXterm*faceSize:18


Save it and exit . ( CTRL O, and CTRL X ). Logout and login again to refect these changes. .
where "terminal" is a font ( you can select another you want ) and 18 is the size.
I also put UXTERM , so this will correct the small size in UXterm.

Enjoy.
salvomic
thank you!
your tips helped, a part of .Xresources that seems not to be active after logout: there are some relevant letter that are to be set small caps or big caps in your listing?
Ctrl+2nd button is ok with TrueType. I'm now also experimenting with resolution of XSDL X server...
I put a bogus file with - inside in home, so I type ls and I've there both - and / to copy/paste...

I wonder why are they / and - missing in the keyboard layout, a mystery...

Salvo
galodoido
QUOTE(salvomic @ Jun 13 2018, 10:42 AM) *
thank you!
your tips helped, a part of .Xresources that seems not to be active after logout: there are some relevant letter that are to be set small caps or big caps in your listing?
Ctrl+2nd button is ok with TrueType. I'm now also experimenting with resolution of XSDL X server...
I put a bogus file with - inside in home, so I type ls and I've there both - and / to copy/paste...

I wonder why are they / and - missing in the keyboard layout, a mystery...

Salvo


Yes , correct is as below

XTerm*faceName:terminal
XTerm*faceSize:18
UXTerm*faceName:terminal
UXTerm*faceSize:18
salvomic
thanks!
galodoido
QUOTE(salvomic @ Jun 13 2018, 11:18 AM) *
thanks!


I forgot this command after :

xrdb -merge ~/.Xresources


salvomic
QUOTE(galodoido @ Jun 13 2018, 05:18 PM) *
I forgot this command after :

xrdb -merge ~/.Xresources


Well, it worked!
Good tips by you.

I wonder if it possible to remap the keys, e.g.

! -> /
£ -> -
Two keys not often used with the two very often used.

Salvo
galodoido
QUOTE(salvomic @ Jun 13 2018, 05:27 PM) *
QUOTE(galodoido @ Jun 13 2018, 05:18 PM) *
I forgot this command after :

xrdb -merge ~/.Xresources


Well, it worked!
Good tips by you.

I wonder if it possible to remap the keys, e.g.

! -> /
£ -> -
Two keys not often used with the two very often used.

Salvo



See this link :

https://askubuntu.com/questions/24916/how-d...keys-or-devices
salvomic
QUOTE(galodoido @ Jun 14 2018, 01:18 AM) *


thanks, I'll try in the afternoon.

salvo
galodoido
QUOTE(salvomic @ Jun 14 2018, 03:34 AM) *
QUOTE(galodoido @ Jun 14 2018, 01:18 AM) *


thanks, I'll try in the afternoon.

salvo


I think this link will help you :

https://michal.kosmulski.org/computing/arti...ayouts-xkb.html

salvomic
QUOTE(galodoido @ Jun 15 2018, 08:58 PM) *


Well, it is very interesting, I'll read it soon.
Maybe assigning - and / to two combination of keys we could solve the problem without change layout...

thanks!

salvo
galodoido
QUOTE(salvomic @ Jun 15 2018, 04:16 PM) *
QUOTE(galodoido @ Jun 15 2018, 08:58 PM) *


Well, it is very interesting, I'll read it soon.
Maybe assigning - and / to two combination of keys we could solve the problem without change layout...

thanks!

salvo

Hi,
You will have to work on /usr/share/X11/xkb/symbols/planet_vndr , file is gemini. Edit it and save it. Make a backup before. ( logout and login to take effect ). I did my custom keyboard to get accents based on a macintosh shortcuts , for examble : option e + letter e = dead acute. (é) . Did the same for other accents and for cedilla. Diferrence is that the option key on mac is ( Fn+shift ) on gemini.
Good luck !


I hope Brazil wins the World cup !
salvomic
QUOTE(galodoido @ Jun 16 2018, 02:44 AM) *
Hi,
You will have to work on /usr/share/X11/xkb/symbols/planet_vndr , file is gemini. Edit it and save it. Make a backup before. ( logout and login to take effect ). I did my custom keyboard to get accents based on a macintosh shortcuts , for examble : option e + letter e = dead acute. (é) . Did the same for other accents and for cedilla. Diferrence is that the option key on mac is ( Fn+shift ) on gemini.
Good luck !


ok,
this week I'll do something.
This issue is one of the few problems I have having with Gemini, altogether a very good device. I hope to find a real and simple solution.

thank again!
salvo
salvomic
I'm trying now with the last Userland Debian version and the issue with dash and slash (- /) already is present: with the Italian Gemini Keyboard both / and - are ok in text only terminal but not in X (via XSDL program): there the keyboard is a mix of Italian and US with strange behaviour: shift-7 is not / but & (as shift-6), FN-* is not - but *, FN-: is not - but .; there are no dash at slash at all...
I wonder if the problem is with Locale or with XSDL or another program (maybe not Userland, as in text mode it works).

What a pity... Userland is a nice program to have Linux inside Android but to use X is a bit tricky (and also ugly).

Salvo
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.