Help - Search - Members - Calendar
Full Version: Debian TP2: no Italian kbd
OESF Portables Forum > Model Specific Forums > Gemini PDA > Gemini PDA - Linux OS
salvomic
there is no Italian Keyboard starting Debian (Flag menu)?
With US kbd to get - I must press * (FN-o) and to get / I must press Shift-;

I set locale, now lxqt is set in Italian, but every Italian keyboard have wrong key mapping for those chars, or not at all...

Any help?
salvo

Adam Boardman
Someone has to add a block for your keyboard to this file:
https://github.com/gemian/xkeyboard-config/...net_vndr/gemini

It lives in /usr/share/X11/xkb/symbols/planet_vndr/ on your device.

Once you've added it there (and tested it with 'setxkbmap -v **', where ** is the country code you've just added) then you'll need to get it added to the xkeyboard-config and to add the new country to this list so that it will appear on the login screen.

You can ask me to do the github stuff if you want to just make and test the layout?
salvomic
QUOTE(Adam Boardman @ Jun 27 2018, 07:18 PM) *
Someone has to add a block for your keyboard to this file:
https://github.com/gemian/xkeyboard-config/...net_vndr/gemini

It lives in /usr/share/X11/xkb/symbols/planet_vndr/ on your device.

Once you've added it there (and tested it with 'setxkbmap -v **', where ** is the country code you've just added) then you'll need to get it added to the xkeyboard-config and to add the new country to this list so that it will appear on the login screen.

You can ask me to do the github stuff if you want to just make and test the layout?


yes Adam, please, be kind to do it, I want test and help to debug, if needed smile.gif
Salvo
Adam Boardman
Building just now, should be ready to test in 30mins.
salvomic
QUOTE(Adam Boardman @ Jun 29 2018, 10:26 AM) *
Building just now, should be ready to test in 30mins.


thanks a lot!
I'll try later smile.gif

salvo
salvomic
I would try,
but with Italian locale in lxqt Terminal (both layout it or us) I get / but not - that is nowhere and I cannot use the combination FN-key with the Gemini keyboard layout...
So, help, please smile.gif

Should I revert to US locale?

salvo

Adam Boardman
So just to check, you've upgraded (apt update 'n' upgrade). Then you logged out and picked from the SDDM menu (Italian flag). Then for example if you went into lxqt keyboard layout selection you'd find it says Planet Computers Gemini as the keyboard model? If not then you've set some custom config that is overriding things, you need to first remove those and then try again.
salvomic
QUOTE(Adam Boardman @ Jun 29 2018, 11:47 AM) *
So just to check, you've upgraded (apt update 'n' upgrade). Then you logged out and picked from the SDDM menu (Italian flag). Then for example if you went into lxqt keyboard layout selection you'd find it says Planet Computers Gemini as the keyboard model? If not then you've set some custom config that is overriding things, you need to first remove those and then try again.


ok!
after apt update upgrade, there is now the Italian flag! I choose it,
Then I choose mapping for Italian Planet Computers Gemini, but now I've / (shift-7) but not - (dash) that in Italian Android Gemini is on FN-. (the key . smile.gif with FN pressed...
How can I use the Gemini combination FN-key?
Otherwise how can I input
setxkbmap -v ?

salvo

EDIT: wow!
I used a tip: input man or other command, select -, then middle key, so I could type
setxkbmap -v
And then I have - also (with FN-.) and all other keys with FN
Thanks!
salvo
Adam Boardman
I think I've muddled you up.

The 'setxkbmap it' is a for this session only way of testing a keyboard layout, so if you were editing the layout locally and then wanted to test your changes you'd run that after each edit of the file.

Once your happy with it you then pick the flag from the sddm login screen once and it sets your system to use that all the time. Next login you just leave it at the 'set by x' or whatever the default is. Remember that you have to press a key on the keyboard for it to know which keyboard its using so the US flag will show until you start typing.

There should be no other keyboard fiddling needed. And any other keyboard fiddling you've done will need undoing before the above will work.
salvomic
QUOTE(Adam Boardman @ Jun 29 2018, 12:30 PM) *
I think I've muddled you up.

The 'setxkbmap it' is a for this session only way of testing a keyboard layout, so if you were editing the layout locally and then wanted to test your changes you'd run that after each edit of the file.

Once your happy with it you then pick the flag from the sddm login screen once and it sets your system to use that all the time. Next login you just leave it at the 'set by x' or whatever the default is. Remember that you have to press a key on the keyboard for it to know which keyboard its using so the US flag will show until you start typing.

There should be no other keyboard fiddling needed. And any other keyboard fiddling you've done will need undoing before the above will work.


thanks again!
it works for the session.
I'm trying doing as you say, but after closing session and open again I cannot see the mod... maybe I've to add it to the keyboard-config. Please, a last help for this smile.gif
Adam Boardman
As I say, you have to remove whatever fiddling you'd done previously with keyboard configs, eg in lxqt delete any keyboard settings you put in there.

Possibly clear things out by making a new user account ('adduser newusername'), then compare the config files from that to the user your currently using.

Why?:
- sddm login screen picking keyboard map will set a system wide keyboard (can be confirmed by flag changing as you type your password)
- lxqt config will override that for a specific user
- setxkbmap will override that for this session (and mess up if USB/BT keyboards have been used)
salvomic
QUOTE(Adam Boardman @ Jun 29 2018, 03:17 PM) *
As I say, you have to remove whatever fiddling you'd done previously with keyboard configs, eg in lxqt delete any keyboard settings you put in there.

Possibly clear things out by making a new user account ('adduser newusername'), then compare the config files from that to the user your currently using.

Why?:
- sddm login screen picking keyboard map will set a system wide keyboard (can be confirmed by flag changing as you type your password)
- lxqt config will override that for a specific user
- setxkbmap will override that for this session (and mess up if USB/BT keyboards have been used)


Well!
I did it and now all went ok!
If only there were the same into GNURoot Debian (now userLAnd) + XSDL inside Android... There I've also troubles with - and /

Thanks Adam, very kind of you.

salvo

Click to view attachment

Now I must correct that message from Perl: "please check that your locale settings are supported..."
Adam Boardman
Fairly certain that you should be able to add your locales? (remember to pick UTF8)

https://github.com/gemian/gemini-keyboard-a...bianTP2#locales
salvomic
QUOTE(Adam Boardman @ Jun 29 2018, 04:26 PM) *
Fairly certain that you should be able to add your locales? (remember to pick UTF8)

https://github.com/gemian/gemini-keyboard-a...bianTP2#locales


yes, I'll do it, controlling all later.
thanks

salvo
salvomic
please, Adam, help: after the installation of the new firmware (here triple boot), I overwrote Linux and again I cannot see the Italian flag (there is more that configuration in this link?).
I made
CODE
apt update; apt upgrade
then input
CODE
setxkbmap -v it-IT
but I get some errors ("error loading the new keyboard description" or also "duplication...") and after reboot I cannot see the Italian flag in the list...

Salvo
Adam Boardman
Keyboard maps and locales are entirely separate. For me the Layout dropdown on sddm login screen has Italian listed, that is the simplest way of picking a keyboard, any other persistent keyboard config eg in lxqt keyboard settings will conflict and get in the way of that setting working beyond the login screen.

For your one off test a keyboard for this session (setxkbmap command) you would only want to be giving it a two letter keyboard code rather than a locale (keyboard+language) style code.
salvomic
QUOTE(Adam Boardman @ Oct 26 2018, 02:16 PM) *
Keyboard maps and locales are entirely separate. For me the Layout dropdown on sddm login screen has Italian listed, that is the simplest way of picking a keyboard, any other persistent keyboard config eg in lxqt keyboard settings will conflict and get in the way of that setting working beyond the login screen.

For your one off test a keyboard for this session (setxkbmap command) you would only want to be giving it a two letter keyboard code rather than a locale (keyboard+language) style code.


yes, I agree with you.
The problem was, as I wrote in another post, the incorrect upgrade process (I got "unmet dependencies" for other reasons) solving that all went gone and at the restart I can see the Italian flag again!

Now I'm on Debian 9.5: are there new version installable (with apt distance-upgrade) or not?

Salvo


EDIT:
some little issue with Perl and Locale.
After some program like Cowsay I get
CODE
perl: warning: Setting locale failed
perl: warning: Please check that your locale settings:
LANGUAGE = "",
LC_ALL = (unset),
LC_MEASUREMENT = "it_IT.US-ASCII",
...
are supported and installed on your system.
perl: warning: Failing back to the standard locale ("C").

Also if Italian seems correctly set in LXQT.
Any help?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.