Help - Search - Members - Calendar
Full Version: No audio after accepting new config during update
OESF Portables Forum > Model Specific Forums > Gemini PDA > Gemini PDA - Linux OS
ZimbiX
Hey guys,

I did an `apt upgrade` yesterday for the first time in about six weeks. In the process, I was prompted whether to replace the existing config for I think PulseAudio. Thinking it'd be fine (and maybe help with the lack of automatic output switching), I accepted the replacement, but after rebooting, sound has not worked at all. Nothing comes out of the speakers or headphone jack. Adjusting the volume from alsamixer doesn't help. I still get the interference noise through the headphone jack when not playing music, which goes away when music is (silently) playing, so it feels like it's almost working.

Do you know of a way to recover this config file?

Is there a logfile which would tell me what file it was? I should have made a note of it!

I'm guessing I'll need to pull it out of the Debian installation image. Maybe mount it somehow in order to do that.

Cheers!
Adam Boardman
The new config should work, and you should find that the old config is saved with a dpkg old extension or similar, you could then experiment with the changes.

Before you resort to that, could you try running the volume control whilst audio is being output and then change the output from 'fast' to 'normal'.

The changes to pulseaudio are related to getting in-call audio to work and automatically switch about based upon audio-jack, open/closed state and orientation (still pending a fix for this last to work properly). If there is anyone who still has the old audio setup I would be interested to know if they had the 'fast' version working or was the auto picking just picking normal? I didn't make any changes in that area so have no idea why that changed if it did.

Logging can be viewed with the journalctl command, see: Debugging

If you do figure anything out then let us know.
Eric BF
Back in January, I upgraded (bringing in the late November kernel, I believe) and I lost sound. When I upgraded recently, as advised to by Adam for other reasons, sound came back. ZimbiX: what kernel are you running?
mithrandir
Just guessing. You might try two things:

1. apt-get -o Dpkg::Options::="--force-confmiss" install --reinstall pulseaudio
(in case some part of your config is borked, afterwards pulseaudio -k or reboot)
2. pactl set-default-sink sink.primary
(Under circumstances it seems sink.fast is default, resulting in no audio)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.